Bug #15248

When deleting a record in the BE, MsgBox should show the record label

Added by Oliver Klee almost 14 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2005-11-30
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I delete a record in the BE in Web > List, I get a message box wit the following text:

Are you sure you want to delete this record?
[Cancel] [OK]

Usability-wise, this could be improved by providing the record label (or the title):

Are you sure you want to delete the record "My Record 1"?
[Cancel] [OK]

In my case, I use a 100dpi display in which the fixed-size fonts of Typo3 are quite small (and even if I increase the font size, the icons stay small), so that I'm not always sure whether I have clicked in the right row. Here it would help if the message box told me which record I'm about to delete. (I'm sure that I want to delete something; I'm just not sure I've clicked on the right record.)

(issue imported from #M1957)

delete_patch.txt View (1.29 KB) Administrator Admin, 2008-08-29 10:47

delete_patch_2.txt View (1.56 KB) Administrator Admin, 2008-08-29 12:11

delete_warning_newmsg.diff View (2.25 KB) Administrator Admin, 2008-08-29 21:24

History

#1 Updated by Oliver Klee almost 14 years ago

For this, sysext/cms/layout/db_layout.php probably needs to be changed. I still don't know where the change needs to go exactly in all these long functions and magic numbers.

#2 Updated by Sebastian Kurfuerst almost 14 years ago

I think typo3/sysext/cms/layout/db_layout.php and typo3/alt_doc.php need to be changed. Just search for deleteRecord inside there to find the JS function.

Maybe it can be changed to use the following:

Table:uid: Are you sure this record can be deleted? (the same text as before, just prefixed with table:uid) - This is easier to do I think...
Anyway I am not sure if this is bad from a usability side. Any comments?
Greets, Sebastian

#3 Updated by Oliver Klee almost 14 years ago

I've just looked through the user interface design guidelines of Windows, Maxc, KDE and Gnome. Those that say something about deleting elements use the following form:

Are you sure you want to delete the record "My Record 1"?

I propose using sprintf to place the element name in the string.

Some KDE apps also use the following form (although I suppose they don't do it that way to improve usability but because it was about 3 lines less to code):

Are you sure you want to delete the following record?
My Record 1

(If JavaScript provided custom buttons labels for alerts, we also should have "Cancel/Delete" buttons instead of "Cancel/OK", but AFAIK JavaScript doesn't support this.)

#4 Updated by Sebastian Kurfuerst over 13 years ago

Hi,
sprintf is a good solution I think.
Is it possible for you to provide a patch for this?

Greets, Sebastian

#5 Updated by Oliver Klee over 13 years ago

Currently, my schedul is really full. I hope that I can come up with a patch in late January or February 2006.

#6 Updated by Rob Vonk about 11 years ago

I added a patch. Can someone test it?

#7 Updated by Peter Foerger about 11 years ago

Why not define $title in one go and also check for it's existance e.g.
$title = $row[$this->fieldArray0] ? $row[$this->fieldArray0] : '';

Besides that the patch workes fine for me. Tested on 4.2.1 as well as 4.1.7

#8 Updated by Rob Vonk about 11 years ago

I added a new patch that also shows info for content elements without title (by taking the first part of the text).

#9 Updated by Rob Vonk about 11 years ago

And added a new patch with new translations for the reference count and a better description for the deletion

Also available in: Atom PDF