Bug #15781

Could not install dam with activated dbal

Added by Joerg Schoppet almost 16 years ago. Updated over 15 years ago.

Status:
Closed
Priority:
Should have
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2006-03-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I've just installed a fresh copy of typo3-4.0rc1pre1.
Then I've installed dbal and adodb, no further configuration.
Then I want to install the newest snapshot of dam "20060228". I recieve the following error message:

ERROR: Query could not be parsed: "SQL engine parse ERROR: Field type unknown in parseFieldDef()!: near "float unsigned default '0', height float unsigned "". Query: "CREATE TABLE tx_dam ( uid int(11) auto_increment, pid int(11) default '0', tstamp int(11) unsigned default '0', crdate int(11) unsigned default '0', cruser_id int(11) unsigned default '0', parent_id int(11) default '0', deleted tinyint(4) unsigned default '0', active tinyint(4) unsigned default '0', sorting int(10) unsigned default '0', hidden tinyint(4) unsigned default '0', starttime int(11) unsigned default '0', endtime int(11) unsigned default '0', fe_group int(11) default '0', sys_language_uid int(11) default '0', l18n_parent int(11) default '0', l18n_diffsource mediumblob, t3ver_oid int(11) default '0', t3ver_id int(11) default '0', t3ver_label varchar(30) default '', media_type tinyint(4) unsigned default '0', title tinytext, category int(11) default '0', index_type char(4) default '', file_mime_type varchar(45) default '', file_mime_subtype varchar(45) default '', file_type varchar(4) default '', file_type_version varchar(9) default '', file_name varchar(100) default '', file_path tinytext, file_size int(11) unsigned default '0', file_mtime int(11) unsigned default '0', file_inode int(11) default '0', file_ctime int(11) unsigned default '0', file_hash varchar(32) default '', file_status tinyint(4) unsigned default '0', file_orig_location varchar(255) default '', file_orig_loc_desc varchar(45) default '', file_creator varchar(45) default '', file_dl_name varchar(100) default '', file_usage int(11) unsigned default '0', meta text, ident varchar(45) default '', creator varchar(45) default '', keywords tinytext, description text, alt_text varchar(255) default '', caption text, abstract text, search_content text, language char(3) default '', pages int(4) unsigned default '0', publisher varchar(45) default '', copyright varchar(128) default '', instructions tinytext, date_cr int(11) unsigned default '0', date_mod int(11) unsigned default '0', loc_desc varchar(45) default '', loc_country char(3) default '', loc_city varchar(45) default '', hres int(11) unsigned default '0', vres int(11) unsigned default '0', hpixels int(11) unsigned default '0', vpixels int(11) unsigned default '0', color_space varchar(4) default '', width float unsigned default '0', height float unsigned default '0', height_unit char(3) default '', PRIMARY KEY (uid), KEY parent (pid), KEY media_type (media_type), KEY t3ver_oid (t3ver_oid) );"

When I uninstall dbal the installation work fine.

(issue imported from #M2792)


Files

fix2.diff (742 Bytes) fix2.diff Administrator Admin, 2006-03-08 09:37

Related issues

Related to TYPO3 Core - Bug #15900: float is not a db-compatible datatypeClosedKarsten Dambekalns2006-03-26

Actions
Is duplicate of TYPO3 Core - Bug #15782: multiplyDBfieldSize and datetimeClosedKarsten Dambekalns2006-03-08

Actions
#1

Updated by Joerg Schoppet almost 16 years ago

Hi,

just noticed, that it is the same problem as described in bug 2793. So I just changed the applied patch.

This is the actual patch.

Also available in: Atom PDF