Bug #15782

multiplyDBfieldSize and datetime

Added by Joerg Schoppet almost 16 years ago. Updated over 15 years ago.

Status:
Closed
Priority:
Should have
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2006-03-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
5
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If $TYPO3_CONF_VARS['SYS']['multiplyDBfieldSize'] is set to a value greater than 1 and you want to install "th_mailformplus" you get the following error-message:

SQL engine parse ERROR: Field type unknown in parseFieldDef()!: near "datetime default '0000-00-00 00:00:00' "

As soon as you lower multiplyDBfieldSize to 1 everything works.

After my opinion the problem lies in class.t3lib_sqlparser.php in the function parseFieldDef(). There is a regex with a lot of db-datatypes, but datetime is missing.

As soon as "datetime" is added everything work fine.
(issue imported from #M2793)


Files

fix.diff (1.68 KB) fix.diff Administrator Admin, 2006-03-08 09:27
fix2.diff (742 Bytes) fix2.diff Administrator Admin, 2006-03-08 09:40

Related issues

Related to TYPO3 Core - Bug #15900: float is not a db-compatible datatypeClosedKarsten Dambekalns2006-03-26

Actions
Has duplicate TYPO3 Core - Bug #15781: Could not install dam with activated dbalClosedKarsten Dambekalns2006-03-08

Actions
#1

Updated by Joerg Schoppet almost 16 years ago

Hi,

just realised that bug 2792 is the same thing.

I've made a new patch.

#2

Updated by Karsten Dambekalns almost 16 years ago

This is not a bug in TYPO3, but a glitch in th_mailformplus. datetime is a MySQL-specific field type, and as such incompatible with the goal of at least making DBAL possible.

Besides TYPO3 never uses date or time types, but always integer to store a unix timestamp. You should submit a bug report to the author of th_mailformplus.

Also available in: Atom PDF