Bug #16567

When adding more than 30 checkboxes on the TCA, the values don't get recorded.

Added by Jesus Hormigo about 13 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2006-09-15
Due date:
% Done:

0%

TYPO3 Version:
4.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

['columns'][fieldname]['config'] / TYPE: "check"

When adding more than 30 checkboxes via the TCA the results don't get recorded if you select any of the checkboxes above the thirtieth.

On the picture attached there is 30 checkboxes that works and save it's values... when you add the 31st box, it doesn't record the value and/or even clears the other values.

If you add

Array("LLL:EXT:wfa/locallang_db.xml:tx_wfa_community.aid_agencies.I.31", ""),

The value of that checkbox don't get saved and might delete the other values.
(issue imported from #M4223)

Maxboxcrop.jpg View (58.6 KB) Administrator Admin, 2006-09-15 13:38

History

#1 Updated by Michael Scharkow about 13 years ago

This restriction is due to checkboxes being set via a bitmask, and the upper limit for an integer is 32bit, so more than 30 is not possible. You have to work around this restriction by grouping your options in multiple fields.

#2 Updated by Christian Kuhn about 11 years ago

Closed as not fixable:

As stated, this is by design, documented and will probably not change in the near future. Add a second field to get more checkboxes.

#3 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF