Bug #16704

Fulltext RTE in IE7 only 10 lines high

Added by Peter Faymonville about 15 years ago. Updated over 14 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2006-11-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In Internet Explorer 7, the height of the fullscreen RTE is only about 10 lines. No problem with IE6 or FF. Version of rtehtmlarea is 1.4.2 on Typo3 4.0.2..

(issue imported from #M4486)

#1

Updated by Pim Broens about 15 years ago

I have looked into it for a second. The problem is that IE7 no longer uses the style="height:100%;" value for the <textarea>. It ignores it and uses the default height.
(In the file /t3lib/class.tx_rtehtmlarea_base.php on Line 597 it could be changed into a height using pixels. The only problem then is the fixed height)

#2

Updated by Martin Kutschker almost 15 years ago

Argh, on my installations it's not 10 lines but 1 pixel. I see no RTE at all !!!

I've seen tips to use "height:auto" or "min-height:100%", but neither works for the RTE.

#3

Updated by Martin Kutschker almost 15 years ago

Solution: add "html { height: 100% }"

#4

Updated by Rickard Andersson almost 15 years ago

I can confirm that Martin Kutschker's tip works. I added the line to sysext\t3skin\stylesheets\stylesheet_post.css and now full screen htmlarea works in IE7. This fix should definitely be incorporated into the next bugfix release.

#5

Updated by Peter Faymonville almost 15 years ago

I can also confirm this fix. This should really be in the next release.

#6

Updated by Martin Kutschker almost 15 years ago

Rejoice! The fix has been added to SVN (both 4.1 and 4.0.4).

Also available in: Atom PDF