Bug #17195

Creation of multiple folders in filelist module results in blank page

Added by Christopher Hlubek almost 14 years ago. Updated about 12 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2007-04-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the filelist module, the creation of more than one new folder returns a blank page. The folders are created though.

This bug is reproducible in TYPO3 Versions 4.0.3 (maybe since 4.0) and 4.1.x too.

How to reproduce the bug:

Filelist Module -> New

Select 2 or more folders, name them e.g. "a","b". Click "Create folders".

-> Blank page!

(issue imported from #M5387)


Files

diff-5387.patch (596 Bytes) diff-5387.patch Administrator Admin, 2008-07-25 17:02
5387_2.diff (600 Bytes) 5387_2.diff Administrator Admin, 2008-07-26 04:41

Related issues

Has duplicate TYPO3 Core - Bug #18175: The folder tree does not reload correctly when creating more than one new folderClosedBenni Mack2008-02-08

Actions
#1

Updated by Christopher Hlubek over 12 years ago

This problem occurs because the redirect value is "forgotten" after selection of more than 1 folder in the drop-down box. I will dig into this...

#2

Updated by Christopher Hlubek over 12 years ago

The returnUrl parameter is not included in the reload function of the select onchange event. Adding the returnUrl value to the url fixes the problem.

file_newfolder.php (142):

function reload(a) { //
if (!changed || (changed && confirm('.$LANG->JScharCode($LANG->sL('LLL:EXT:lang/locallang_core.php:mess.redraw')).'))) {
var params = "&target="+escape(path)+"&number="+a+"&returnUrl="+escape("'.$this->returnUrl.'");
window.location.href = "file_newfolder.php?"+params;
}
}

#3

Updated by Christian Kuhn over 12 years ago

Thanks Christopher!

+1 reading and testing.

I just added whitespaces around concatenation dots and will now send your patch to core list.

Also available in: Atom PDF