Feature #17253

indexed_search should allways include indexed pages for "not logged in" user

Added by Bernd Hanisch over 12 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
Indexed Search
Target version:
-
Start date:
2007-04-27
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

logged in users dont get a result of queries, if they no member of the same groups visit the page before.

i request to include the patch of Zappelphilipp posted at http://www.typo3.net/forum/list/list_post//53493/ to include in the core of indexed_search.

Thx Bernd

(issue imported from #M5510)


Related issues

Related to TYPO3 Core - Bug #16597: FE- Users with more than one group get wrong searchresults Closed 2006-09-26
Related to TYPO3 Core - Feature #17630: gr_list concept needs to be improved New 2007-09-27

History

#1 Updated by Daniel Poetzinger about 12 years ago

i aggree.
I just update a big intranet from 3.8 to 4.1.1

behaviour in 3.8:
- the indexed search cache is build with wget (no login)
- every websiteuser is logged in.
- they can find results in indexed search

behaviour in 4.1.1 (with indexed serach 2.10)
- user are not able to find any results


I suggest a new configuration directive in indexed_search:
.filterResults=(no|strict|hasaccess)

with this behaviour:
- no: no filtering: all results found are shown (if usergroup did not match we can show a message like "result is indexed for another group - view may differ")
- strict: result are filtered strict: means only results are shown which has the same grlist (like it is now)
- hasaccess: only page permissions are checked (if user has access to the page the result is shown. -> i guees this will be best default setting.


=> i guess we are able to sponsor this feature/bug. Please contact me.

#2 Updated by Valery Romanchev almost 12 years ago

related to #0006403

#3 Updated by Dmitry Dulepov about 9 years ago

That patch comes from somebody, who does not understand how indexed search works...

When you index, you must specify exactly what group combinations your users have. For example, if a page has group combinations like: "0,-1", '0,-2,1,2" and "0,-2,2,3" but your user has "0,-2,3,2", nothing will be found! The list must match exactly. Notice that 0,-1 is always for anonymous and 0,-2 is prepended to any groups that user has. But groups still must match ones you have in the crawler configuration. That's all.

Not a bug really. This about understanding only.

#4 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF