Bug #16597

FE- Users with more than one group get wrong searchresults

Added by Carsten Kleinfeld over 14 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2006-09-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

if there is grlist=1 for a searchresult and a user is in the groups #1 and #2
the user won't get this result.

(issue imported from #M4286)


Related issues

Related to TYPO3 Core - Feature #17253: indexed_search should allways include indexed pages for "not logged in" userClosedDmitry Dulepov2007-04-27

Actions
Related to TYPO3 Core - Feature #17630: gr_list concept needs to be improvedNew2007-09-27

Actions
#1

Updated by Michael Stucki almost 14 years ago

Have a look at Web>Info>Indexed Search>Technical Information:
The page needs to be indexed for every group combination, even if the content is the same.

So for instance, if your user is in groups 1 and 2, but the page was only indexed by a user who is in group 2, then he won't find the document.

I have tested this very thoroughly and are almost convinced that this is not a bug!

#2

Updated by Daniel Poetzinger over 13 years ago

see related: 5510

#3

Updated by Alexander Opitz almost 8 years ago

  • Status changed from Accepted to Closed
  • Target version deleted (0)
  • TYPO3 Version set to 4.0

As this is not a bug and the mentioned #M5510 (#17253) is resolved I close this old one.

Also available in: Atom PDF