Bug #17351

Backend forms show value "XX" in empty select lists in Firefox 2.0.4

Added by Christopher Hlubek over 13 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2007-06-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Empty select lists (not drop-down) print the value "XX" after mouseover. This issue appeared in all of our independent installations (>4.1) after Firefox update to version 2.0.4, it doesn't appear in IE.

(issue imported from #M5728)


Files

screenshot-bug.gif (3.64 KB) screenshot-bug.gif Administrator Admin, 2007-06-01 14:44
0005728_experimental.patch (501 Bytes) 0005728_experimental.patch Administrator Admin, 2007-06-03 15:58
#1

Updated by Oliver Hader over 13 years ago

I can confirm this on a clean TYPO3 4.1.1 installation but don't know what causes this. I could not reproduce scenarios outside TYPO3, e.g. testing with a simple HTML file and selectors. Maybe an JavaScript issue?

#2

Updated by Oliver Hader over 13 years ago

I spent some time on this issue:
In typo3/sysext/t3skin/stylesheets/stylesheet_post.css there is a "select:hover" definition, which causes this behaviour. Firefox seems to evaluate this wrong. But I also don't know why we need hover effects on select, input and textarea in t3skin.

"Test" the attached experimental patch which just changes the CSS file.

#3

Updated by Peter Foerger over 13 years ago

Hi Olly,
works fine here. FF 2.0.0.4 on OSX 10.4.9

cheers
Peter

#5

Updated by Oliver Hader over 13 years ago

Due to Firefox bug 382600 this isn't a TYPO3 issue at all. So, I'm closing this issue.

Also available in: Atom PDF