Bug #17625

sortby with 2 fields will crash on sorting & adding new record

Added by Georg Ringer over 13 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2007-09-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

It is not possible to sort records of a table in list view anymore if a 2nd sorting field is added in ext_tables.php

to reproduce: create an extension with a table with manual sorting activated and modify ext_tables.php
-----
'sortby' => 'mode, sorting',
-----

errors
-----
SELECT mode, sorting,pid,uid
FROM tx_rgproduct_piece
WHERE
=> pid=46 AND mode, sorting>=0 AND tx_rgproduct_piece.deleted=0
ORDER BY mode, sorting ASC
LIMIT 2
-----

what do you think?
(issue imported from #M6391)

#1

Updated by Manuel Palkowitsch over 13 years ago

Hi Georg,

I have the same problem. I can not sort records on my own extensions.
In TYPO3 Version 4.1. it works, but not in 4.1.2.
Has any one an idea?

Thx for help.

#2

Updated by Martin Kutschker over 13 years ago

I think this is afeature request for "manual sorting withing a group". Currently you can either use your own sort fields or let TYPO3 do the mnualy sorting with the "sorting" field. If you want to change that it needs more than simply adding an extra sort field in the SQL query. TYPO3 should know of it so it can change thes orting field in a meaningful way.

#3

Updated by Georg Ringer over 13 years ago

yeah it is both, feature & bug because the sorting alone is working. netherless it would be a nice cool feature

#4

Updated by Alexander Opitz almost 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#5

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed

No feedback for over 90 days.

Also available in: Atom PDF