Bug #17814

Implement option to use different Flexform Datastructures per type field value (e.g. CType)

Added by Ingmar Schlecht about 13 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2007-11-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Currently it's not possible to make tceforms use different Flexform datastructures for the pi_flexform field based on the Content Type (CType) of the tt_content table because the plugin field ("list_type") is already defined to be the ds_pointerfield in this case.

However, to have Flexform configuration for the "table" and "login" Content Elements as well, it would be necessary to optionally define different DataStructures per CType.

The attached patch therefore introduces the new option "ds_altSrcPointer_perType".

The patch also patches css_styled_content to use that new option instead of overriding the whole "default" DS key.

(issue imported from #M6770)


Files

ds_altSrcPointer_perType.patch (2.65 KB) ds_altSrcPointer_perType.patch Administrator Admin, 2007-11-20 01:41
#1

Updated by Benni Mack about 13 years ago

Ingmar, isn't this in trunk yet?

#2

Updated by Christian Kuhn over 12 years ago

This has been commited by Ingmar at 2007-11-24 with revision 2760.

Please set to resolved and closed.

#3

Updated by Christian Jul Jensen over 12 years ago

Fixed by ingmar in rev2770

Also available in: Atom PDF