Bug #17959

Section-based FCEs are saved with incorrect element ID

Added by Jeff Segars almost 12 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2007-12-31
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When working with trunk and FCEs that have sections defined, saving the FCE results in bad data in the the FCE XML. Instead of an element like
<section index="1">
I end up with
<field index="ID-edd5ba543c-idx36456-form">

This data results in PHP errors in both the frontend and in the TV Page Module.

From what I can tell, these IDs are related to the FCE changes in changeset 1628. In TCEMain, the temporary IDs are mapped into normal section indexes, and the normal section elements are saved FCE XML. In the current code, this mapping only occurs if the element is not new. When I move the mapping outside this check so that it always occurs, saving and rendering work fine for me.

I'm attaching the patch for this issue. I don't fully understand all the code at this point in TYPO3 so there may be better ways to get it done, but it does seem to work for me.

(issue imported from #M7067)

class.t3lib_tcemain.php.diff View (1.96 KB) Administrator Admin, 2007-12-31 06:09

History

#1 Updated by Dmitry Dulepov over 11 years ago

I think patch is correct.

Jeff, do you mind submitting it yourself to core list?

#2 Updated by Jeff Segars over 11 years ago

Sure thing. I'll do a little more testing here since I vaguely remember a few changes around this code since the ticket was originally opened.

#3 Updated by Alexander Opitz over 6 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#4 Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Jeff Segars)
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF