Bug #17978

Problem with cms\tslib\index_ts.php

Added by Tapio Markula over 13 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-01-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi

Why \cms\tslib\index_ts.php concerning frontend editing.

older versions frontend editing sfuff wa here

$BE_USER->extInitFeAdmin();
if ($BE_USER->extAdmEnabled) {
// frontend editing here

in new file later

// *********************************
// Frontend editing
// *********************************
if ($TSFE->beUserLogin && $BE_USER->extAdmEnabled) {

The change violates pluging pixe_feediting and presumably mk_tvfronend,
which calls templavoila api function this way:

$sourcePointerString = $this->TSFE_EDIT['flexformPointer'];
$sourcePointer = $this->flexform_getPointerFromString ($sourcePointerString);
$apiClassName = t3lib_div::makeInstanceClassName('tx_templavoila_api');
$TVObj = new $apiClassName ($sourcePointer['table']);

Calling of api function doesn't work as expected - works after reloading page.

file cms\tslib\index_ts.php from Typo3 4.1.1 solved the problem.

file cms\tslib\index_ts.php from Typo3 4.1.1 solved the problem

Just replace in newer version the existing file with older one
(issue imported from #M7121)


Related issues

Related to TYPO3 Core - Bug #16526: Moving content elements in frontent editing mode causes crashClosedThorsten Kahler2006-09-06

Actions
Related to TYPO3 Core - Feature #18265: Add post processing hooks for Frontend EditingClosedJeff Segars2008-02-21

Actions
#1

Updated by Oliver Hader over 13 years ago

The code you mentioned was changed to fix bug #16526

#3

Updated by Tapio Markula over 13 years ago

related bug: http://bugs.typo3.org/view.php?id=4160

Then imo the solution is not good because it cause more problems.
Personally I have fixed the problem, which has been explained in
the bug 0004160 exactly the way which Beat Zimmerli proposed.

The solution of Typo3 4.1.3 and newer is just totally intorable for my plugins.
It destroyes bad way functinalities in pixe_feediting and because it has some functionalities from mk_tvfrontend, this solutions destroys the functionality of mk_tvfrontend too.
Maybe all plugins, which use XCLASS for class.t3lib_tsfebeuserauth.php don't work properly after this change.

#4

Updated by Jeff Segars over 13 years ago

This has been fixed in ticket #18265 by adding a 2 hooks after frontend editing actions are performed. You can use the hooks to call TSFE->determineID() or any other methods you need.

Also available in: Atom PDF