Bug #17997

backend.php top menu broken in Safari 3 when in localhost

Added by Stefano Cecere almost 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-01-15
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

(i passed to Safari 3.0.4 a few days ago, that's why i'm finding all these bugs)

the top menu in backend.php has really strange problems with latest trunk/safari?

see attached screenshot: it appears when i click on the search icon (and with clear cache and the new shortcut menu) : the screen does shift 5 pages to the right!

the problem is that it happens only when using localhost

http://localhost/site/typo3/backend.php

if i use:

http://127.0.0.1/site/typo3/backend.php

it works well

i found a similar problem with IRRE this afternoon, but it was corrected clearing Safari's cache (as oliver suggested.. he changed the js/ajax library yesterday). anyway here this trick doesn't work....

uhmmm

(issue imported from #M7162)

Picture 2.png View (34.5 KB) Administrator Admin, 2008-01-15 18:02

Picture 3.png View (28 KB) Administrator Admin, 2008-01-15 18:12


Related issues

Related to TYPO3 Core - Bug #18007: GUI of new backend is mixed up in IE6 Closed 2008-01-16
Related to TYPO3 Core - Bug #22479: Positioning of toolbar elements broken, especially in Safari Closed 2010-04-17

History

#1 Updated by Stefano Cecere almost 12 years ago

found another error: bot safari AND firefox, using both 127.0.0.1 and localhost give the errror, when adding a new shortcut, as screenshot Picture 3.png

#2 Updated by Stefano Cecere almost 12 years ago

uhm.. the problem still exists ever after trunk 2921 (ie: with patch to bug 0007178 applied)

#3 Updated by Oliver Hader almost 12 years ago

Okay, I can reproduce the behaviour with clicking on the "Shortcuts" icon, "Clear cache" icon or the "Search" icon in the top bar which seems to be a CSS issue.

But I could not reproduce the error popup with "ShortcutMenu::render".

#4 Updated by Oliver Hader almost 12 years ago

Hm, after clearing cache, this seems to be working now in my Safari browser. Strange...

#5 Updated by Stefano Cecere almost 12 years ago

yes, the ShortcutMenu::render has disappeared.

anyway i see that sometime the scroll problem is fixed.. but i reload the page, and it comes back..
uhmm.

#6 Updated by Stefano Cecere almost 12 years ago

found this clue:

when i load the backend.php , usually the top menus are broken..

BUT if i resize the Safari window.. everything gets corrected (the navtree frame, the top menues..)

so it seems that Safari doesn't automatically get the correct window size?

#7 Updated by Chris topher over 9 years ago

Is automatically getting the correct window size still a problem in Safari, Stefano?

I don't think so...

#8 Updated by Chris topher over 9 years ago

Should have been fixed with #22479 at least.

Also available in: Atom PDF