Bug #18007

GUI of new backend is mixed up in IE6

Added by Oliver Hader almost 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-01-16
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The interface of the new backend looks a bit "ugly" in Internet Explorer 6. The topbar has wrong CSS settings and is spread over the screen.

(issue imported from #M7178)

42alpha3_on_ie6.png View (40.5 KB) Administrator Admin, 2008-01-16 20:11

test.html View (503 Bytes) Administrator Admin, 2008-01-17 11:19

be.png View (78.7 KB) Administrator Admin, 2008-01-17 11:19

fix_ie6.diff View (567 Bytes) Administrator Admin, 2008-01-17 13:22


Related issues

Related to TYPO3 Core - Bug #17997: backend.php top menu broken in Safari 3 when in localhost Closed 2008-01-15

History

#1 Updated by Oliver Hader almost 12 years ago

See attached screenshot.

#2 Updated by Ingo Renner almost 12 years ago

IE6 needs a width for those elements, the problem is that they can change their width depending on f.e. username length, localized labels, FE preview on/off for workspaces.

edit: solution could be to redirect IE6 user to alt_main.php

#3 Updated by Oliver Hader almost 12 years ago

Unfortunately there are quite a lot of people which use IE6. Imagine video tutorial showing the new features of TYPO3 4.2 and the frustration of IE6 users watching these videos and having no clue why they can't use it...
Thus, I tend to have a new backend for all current browsers and versions. Just my two cents.

#4 Updated by Ingo Renner almost 12 years ago

of course! we "just" need to find a solution ;-)

maybe calculating the width from the counted chars or so =/ (hack)

#5 Updated by Nikolas Hagelstein almost 12 years ago

There is no need to define the with the solution is quite simple.
Set the height of all inner li divs to auto instead of 23px.

I attached a simple sample to play arround with
and a screenshot of the backend with height set to auto.

#6 Updated by Ingo Renner almost 12 years ago

here's a patch

#7 Updated by Ingo Renner almost 12 years ago

thanks Nikolas!

#8 Updated by Ingo Renner almost 12 years ago

fixed in trunk

Also available in: Atom PDF