Bug #22479

Positioning of toolbar elements broken, especially in Safari

Added by Helmut Hummel almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-04-17
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After introducing the viewport layout to the backend (#22319), the toolbar menu positioning is not correct.

I tested it in Firefox, where the positioning is OK when the backend is loaded, but misplaced by 2px after resizing, and in Safari on Mac where the positioning is misplaced by ~100px after loading and 2px after resizing the window.

See attached Screenshots
(issue imported from #M14144)

Safari_before resize.png View (20.2 KB) Administrator Admin, 2010-04-17 16:24

Safari_after_resize.png View (21.1 KB) Administrator Admin, 2010-04-17 16:24

Firefox_before_resize.png View (25.1 KB) Administrator Admin, 2010-04-17 16:25

Firefox_after_resize.png View (26.3 KB) Administrator Admin, 2010-04-17 16:25

14144.diff View (10.5 KB) Administrator Admin, 2010-04-23 19:48


Related issues

Related to TYPO3 Core - Bug #22319: Add Viewport layout to BE Closed 2010-03-23
Related to TYPO3 Core - Bug #22606: BE search is broken Closed 2010-05-07
Related to TYPO3 Core - Bug #17997: backend.php top menu broken in Safari 3 when in localhost Closed 2008-01-15

History

#1 Updated by Steffen Gebert almost 10 years ago

Can reproduce the problem in Safari

#2 Updated by Stefan Galinski almost 10 years ago

At least the firefox issue isn't related to the viewport patch! I got the same problem with TYPO3 4.3. I will try to fix the issue anyway...

#3 Updated by Stefan Galinski almost 10 years ago

Great! Both bugs are issues with prototype or the current toolbar implementation. Nothing seems to be releated to my viewport patch directly. A patch follows soon...

#4 Updated by Soren Malling almost 10 years ago

I guess this is a misspell? :

- Toolbar: null,
+ TopbBar: null,

and

- this.Toolbar = Ext.ComponentMgr.get('typo3-toolbar');
+ this.TopbBar = Ext.ComponentMgr.get('typo3-topbar');

Shouldn't it be

+ TopBar: null,

and

+ this.TopBar = Ext.ComponentMgr.get('typo3-topbar');

without lowercase "b"? Or what is the extra b for ? :)

#5 Updated by Stefan Galinski almost 10 years ago

Hi Soren,

You are completely right. I will fix that in a second version of the patch. Currently I must wait for the integration of http://bugs.typo3.org/view.php?id=14195.

#6 Updated by Steffen Kamper almost 10 years ago

committed to trunk rev 7521

Also available in: Atom PDF