Bug #18006

Page tree is not working in IE6/IE7

Added by Mads Brunn almost 14 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-01-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The page tree is not working properly in IE7!

When I try to expand a subtree (clicking on a "+" icon) nothing happens (but it works when I try to collapse a branch).

Everything works as expected in FireFox.

I haven't tested it in IE6 so I don't know if there is a problem with that version too.

(issue imported from #M7177)


Files

0007177.patch (524 Bytes) 0007177.patch Administrator Admin, 2008-01-17 15:55

Related issues

Related to TYPO3 Core - Feature #17970: Consistent interface for AJAX calls in the TYPO3 BackendClosedBenni Mack2008-01-07

Actions
Related to TYPO3 Core - Bug #17984: clickmenu on list module icons does not workClosedBenni Mack2008-01-11

Actions
#1

Updated by Oliver Hader almost 14 years ago

I can confirm this for IE6 and IE7:
Microsoft Script Debugger tells me that line 1368 of prototype.js should be the reason, there's the following:

this.responseText = String.interpret(transport.responseText);

But I don't believe Microsoft and think it's another reason. The same bug occours with IRRE. Maybe a flaw in our new AJAX interface (but I cannot imagine what, except headers or encoding).
#2

Updated by Oliver Hader almost 14 years ago

The bug was introduced with revision 2878 (rev. 2877 works):
Added #17970: Consistent interface for AJAX calls in the TYPO3 Backend

#4

Updated by Oliver Hader almost 14 years ago

Yes, but I think that this won't help in this case. As I mentioned, the bug occoured with rev. 2878 and had no problems before.

#5

Updated by Nikolas Hagelstein almost 14 years ago

IE6 works for me.

#6

Updated by Nikolas Hagelstein almost 14 years ago

IE7 and IE6 works for me, but i i have to admit, that i set BE charset to iso8859-1 perhaps it is related to some charset issues.
cheers,
Nikolas

#7

Updated by Oliver Hader almost 14 years ago

Yepp, this is a charset issue. I'm going to provide a patch for it.

#8

Updated by Oliver Hader almost 14 years ago

Committed to SVN Trunk (rev. 2920)

Also available in: Atom PDF