Bug #18118

CSS Gremlins in t3skin

Added by Jeff Segars almost 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-02-05
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

From a thread on the dev list, we came up with a list of simple CSS gremlins in t3skin that can be addressed quickly. The attached patch fixes the following issues...

1. Links are not underlined (For now, all links are underlined but this means a lot of stuff is underlined. We may want to revisit this).
2. Remove borders and background colors from select fields.
3. File->Filelist has an old-style table header.
4. File->Filelist has an unstyled table when using clipboard #1.
5. Web->Info tables are not styled at all in the pagetree overview.
6. TCEForms record header has a background in IE.
7. Task Center horizontal tab menu on the left still has old skin colors and background.
8. Category treeviews like in tt_news have some extra pixels between the records.

(issue imported from #M7388)

20080204_css_gremlins.diff View (9.15 KB) Administrator Admin, 2008-02-05 06:32

20080207_css_gremlins.diff View (10.8 KB) Administrator Admin, 2008-02-07 19:26

20080209_new_menu_taskcenter.diff View (7.88 KB) Administrator Admin, 2008-02-09 17:32

20080211_css_gremlins.diff View (12.4 KB) Administrator Admin, 2008-02-11 18:46

20080211_css_gremlins_v3.diff View (13.9 KB) Administrator Admin, 2008-02-11 21:09


Related issues

Related to TYPO3 Core - Bug #18166: Category Treeview in BE-Forms has gap between 2 lines Closed 2008-02-08
Related to TYPO3 Core - Bug #17670: links in BE not underlined in t3skin Closed 2007-10-11
Related to TYPO3 Core - Bug #16172: class typo3-goBack not set Closed 2006-05-23
Related to TYPO3 Core - Bug #18206: New Menu in Taskcenter Closed 2008-02-13

History

#1 Updated by Jeff Segars almost 12 years ago

Updated with new version of the patch.

1. Removed the underlines again, since we need some discussion about what should actually be underlined.
...
9. Module menu text is unaligned due to different icon sizes
10. CSH in the second row of the docheader looks different
11. Icons in the second row do not sit at the same vertical position as ?the text

#2 Updated by Steffen Kamper almost 12 years ago

hey Jeff, excellent work!

#3 Updated by Steffen Kamper almost 12 years ago

tested both patch and works good for me.

Taskcenter - left buttons are not nice though.
I would suggest to replace the DynMenu with a prototype driven Menu with a normal ul-list.

#4 Updated by Jeff Segars almost 12 years ago

Thanks for testing Steffen. I agree the task center icons are not good, but if we're not going to change the underlying HTML right now, do you think the styling is decent enough for the time being?

I'll go ahead and propose this patch and we can provide a better fix later on.

#5 Updated by Steffen Kamper almost 12 years ago

I replaced the dynTabMenu with a normal list.
Advantages:

  • html is normal ul-list
  • collapse/expand is prototype-driven
  • status is saved in Usersettings via Ajax

I also removed the height-bug when edit a record in taskcenter.

Patch is attached.

#6 Updated by Jeff Segars almost 12 years ago

Added a new version of the patch that cleans up styling in the Filelist module where the spacer gif was removed.

#7 Updated by Jeff Segars almost 12 years ago

And another new version of the patch, after a testing session with Benni

12. Added better styling for CSH popup windows and info windows.
13. Removed red SU User background color and replaced with bold red text instead.

#8 Updated by Steffen Kamper almost 12 years ago

i think bold is too less to ack that it's a super user.
Whats about giving red border, may be on the left only?

#9 Updated by Jeff Segars almost 12 years ago

Steffen and I discussed this on IM and he's fine with the red text color, as long as something is red :)

#10 Updated by Jeff Segars almost 12 years ago

Committed to 4.2 branch.

Also available in: Atom PDF