Bug #18508

config.xhtml_cleaning = all mixes up inline JavaScript. Should be documented.

Added by Christopher Schnell over 12 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Documentation
Target version:
-
Start date:
2008-03-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There is an issue (according to Christopher Torgalson for years) with the xhtml-cleaning that mixes up inline JavaScript in a html-template file.

Since there seems to be no chance for a fix anytime soon, it should be documented in the appropriate TSref section saying something like "warning: may ^$#@!$^& inline javascript".

Below is a conversation from the dev-mailing list, that lead to this entry

1. Christopher Schnell:
If the page with a line like this is rendered by the frontend, the next
lines in the script-code are absolute rubbish. Some chars are missing,
others are replaced, linebreaks disappear, just pure rubbish. If I open
the same script in fileadmin again, it is perfectly well.

2. Oliver Klee:
This sounds like you're using some kind of HTML cleaning that happily
processes the innocent JavaScript.

3. Christopher Schnell:
You are absolutely right. it was: config.xhtml_cleaning = all
When I disable xhtml-cleaning, it works perfectly. Now the question
would be if config.xhtml_cleaning is a part of TYPO3 and if it is a bug
or not. Should I report to BT?

4. Christopher Torgalson:
The issue has been known for at least a couple of years, so without a
patch, I doubt it'll get fixed soon and the problem won't be solved.
What I'd suggest instead is filing a bug report re: the appropriate
section in the TSref saying something like "warning: may ^$#@!$^&
inline javascript".
(issue imported from #M7952)


Related issues

Is duplicate of TYPO3 Core - Bug #14988: xhtml_cleaning corrupts javascript in HTML-comment from extensionClosed2005-09-22

Actions
#1

Updated by Michael Stucki over 12 years ago

This doesn't require documentation but must simply be fixed. See #1477.

#2

Updated by Robert Heel about 6 years ago

1+

#3

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF