Bug #18554

not longer possible to use non-integer uids for fake treeitems in class.t3lib_treeview.php [has fix]

Added by Franz Koch over 11 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-04-03
Due date:
% Done:

0%

TYPO3 Version:
4.1
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Due to a codechange in 4.1.x it's no longer possible to use non-integer uid values for the tree-data. When a non-integer value is used, a TYPO3 error is shown and the script is exiting/crashing. In my case I'm using a mixture of strings and integers as keys (alphabetic grouped usernames) and since I updated to TYPO3 4.1.x this is no longer possible (worked with 4.0.2 f.e.).

The line causing this is line 773 of class.t3lib_treeview.php (current SVN, TYPO3 4.2 trunk):
if ($newID==0) {

This line has to be changed in one of the two ways in order to get this back working:
a) if ($newID=='0') {
b) if(empty($newID) {

Would be nice if this could be changed to get it working again.

(issue imported from #M8006)

History

#1 Updated by Christian Kuhn over 11 years ago

I don't understand. What is a fake tree item? And how do you manipulate a page (?) uid in the backend?

#2 Updated by Franz Koch over 11 years ago

The treeView class is f.e. also used by DAM and probably some other extensions. If you would like to use the treeView class with items that have a non-integer ID (like a alphabetic tree) it won't work.

"Fake items" is the wrong wording - I forgot to change that in the title. But initially I meant custom items with it.

#3 Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#4 Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF