Bug #18711

Header and fields of a child record do not seem to belong together visually

Added by Oliver Hader over 11 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-04-26
Due date:
% Done:

0%

TYPO3 Version:
4.1
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Header and fields of a child record do not seem to belong together visually. Something like a border around the header and fields section of each child record is missing.

Thanks to Ingmar Schlecht for the initial patch!
(issue imported from #M8267)

irre_before.png View (38.2 KB) Administrator Admin, 2008-04-26 22:56

0008267.patch View (4.16 KB) Administrator Admin, 2008-04-26 23:40

irre_after.png View (49.1 KB) Administrator Admin, 2008-04-26 23:40

0008267_v3.patch View (4.43 KB) Administrator Admin, 2008-06-13 18:41

irre_after2.png View (24.8 KB) Administrator Admin, 2008-06-14 20:49

History

#1 Updated by Georg Ringer over 11 years ago

Hi,

FYI: IE6 can't display dotted, maybe we take dashed instead because it should look the same everywhere?

#2 Updated by Steffen Kamper over 11 years ago

much better in irre_after!

What do you think about displaying +/- icon in collapse title bar to make visible that it can be collapsed/expanded ?

#3 Updated by Steffen Kamper over 11 years ago

Hi olly,

have a look to my proposal, i would like to have it a bit clearer
(irre_after2.png)

a) darker background for the IRRE-childs to have it clear as different section
b) make complete section collapsable and shows count of childs

what do you think?

#4 Updated by Oliver Hader over 11 years ago

Thanks for the proposal!

I'm fine with the darker background.
To be consequent with the collapsable section/icon, also the header of each child record would require such icon. Also the count of items is a nice idea. However there are some (technical) side-effects:

  • plural of object, e.g. "prices", "offers" is not possible or you have to define the plural for each object name - adding only an "s" for English Plural would not work in all cases - in German its more difficult, e.g. for "Preise" or "Hotels" -> so we just use "items" or "item"
  • each dynamic action (e.g. localizing/synchronizing) records has to take care about this correct count
  • notification of unfilled required fields has to be taken into account for the collapsable section

By the way: Since this is a HCI issue, where do we want to discuss? There's also an issue on forge: http://forge.typo3.org/issues/show/782
Personally I'd like to discuss it on forge.typo3.org. What do you think?

#5 Updated by Steffen Kamper over 11 years ago

sure, good to have it linked now, let's continue on forge.

#6 Updated by Alexander Opitz over 6 years ago

  • Status changed from Accepted to Closed
  • Target version deleted (0)

Closed as this is beeing done. And it looks good.

Also available in: Atom PDF