Bug #18819

felogin redirect won't work if "hide at login" is selected

Added by Amael Doe over 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Should have
Category:
felogin
Target version:
-
Start date:
2008-05-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If the page containing the felogin plugin make use of the "hide at login" option, redirection does not work anymore.

(issue imported from #M8468)


Related issues

Related to TYPO3 Core - Bug #18936: redirect after logout does not workClosedSteffen Kamper2008-06-11

Actions
Has duplicate TYPO3 Core - Bug #22995: fe_login redirection not workingClosedOliver Hader2010-06-25

Actions
#1

Updated by Jacco Lammers over 12 years ago

I can reproduce the problem on:
TYPO3_VERSION: 4.2.6
PHP_VERSION : 5.2.6
felogin: 1.0.0

#2

Updated by Federico Bernardin almost 12 years ago

I find the same problem, when set "hide at login" the login page, redirect doesn't work anymore.

#3

Updated by Thomas Hirt over 11 years ago

Hi!
I can reproduce this even in TYPO3 4.3.3
I think this is a very important feature. I would like to hide the menupoint login and redirect the user directly to some special pages.
I hope someone will take care of this soon ;)
Thanks for your hard work.

#4

Updated by Thomas Deinhamer over 11 years ago

Hello,
this "bug" is still present in 4.4.0 and I also think it's a very common usecase to show a login page only when logged out and make a redirect to another page after logging in.

Is there already an idea or a solution how to change the login process of the extension, to ensure redirection after login?

#5

Updated by Jigal van Hemert over 11 years ago

This can't be solved inside felogin. The core first handles the login checks, then the page access and finally when the plugin is displayed it will handle the redirect.
The new manual tells you more about the process.

Solutions can be found in for example:
- including the felogin plugin with Typoscript in each page (invisible with CSS if necessary) and let that handle the redirects
- using shortcuts in the menu. Keep the real login page accessible and using the 'hide at login' on the shortcuts

#6

Updated by Thomas Deinhamer over 11 years ago

Actually I'm using the login via TypoScript on every page. Sorry, where can I find the examples and the felogin documentation? Thanks a lot!

#7

Updated by Mathias Schreiber over 11 years ago

closed due to logical error in setup.
Bottomline:
felogin does the redirect, if felogin is hidden for whatever reason, it can't redirect.

#8

Updated by Thomas over 10 years ago

Workaround for this issue:

Remove login page from menu. Has the same effect.

TypoScript:

//constants
[loginUser = *]
excludeFromMenu = 4711
[global]

//setup
// in menu config
excludeUidList = {$excludeFromMenu}

#9

Updated by Brian Hauge Hansen almost 10 years ago

Thomas wrote:

Workaround for this issue:

Remove login page from menu. Has the same effect.

TypoScript:

//constants
[loginUser = *]
excludeFromMenu = 4711
[global]

//setup
// in menu config
excludeUidList = {$excludeFromMenu}

Is it possible to us conditions in a menu?

UPDATE

Of cause you can:

[loginUser = *]
lib.mainMenu.excludeUidList = 86
[global]

Also available in: Atom PDF