Bug #18869

File-Bug in Extensions by translation

Added by Lee Perry about 14 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-05-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi there,

I'm working with the final version of TYPO3 4.2 and I have a field in one of my own extension with a internal_type "file" for an image or another file:

"pdf" => Array (
"exclude" => 1,
"label" => "LLL:EXT:my_lawyer_management/locallang_db.xml:tx_mylawyermanagement_issues.pdf",
"config" => Array (
"type" => "group",
"internal_type" => "file",
"allowed" => "",
"disallowed" => "php,php3",
"max_size" => 50000,
"uploadfolder" => "uploads/tx_mylawyermanagement",
"size" => 1,
"minitems" => 0,
"maxitems" => 1,
)
),

I can use it in the standard language smoothly. But when I translate it, the whole server-path is inserted in the input-field for the file and so I got a warning and the error-message "1: Could not delete file" by saving, because of the double server-path - after that it's all okay - but it's irritating for the editor.

Is it a bug or a missing configuration?

Thanx,
Lee

(issue imported from #M8550)

#1

Updated by Maxime Lafontaine over 13 years ago

I got the same error but in a flexcontent.

10 = IMAGE
10.file.import = uploads/tx_templavoila/
10.file.import.current = 1
10.file.import.listNum = 0
10.file.width = 90c
10.file.height = 65c
10.altText.stdWrap.field = field_alt

It's just like the generated typoscript, for most part.
Can it be an misconfiguration of the server?

It do the error in my default language.

I use TYPO3 4.1.5 with templavoilà 1.3.3

It's really urgent.

#2

Updated by Alexander Opitz about 9 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3

Updated by Alexander Opitz almost 9 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF