Bug #19264

External URLs cannot be set in RTEhtmlarea anymore

Added by Oliver Hader about 11 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2008-08-29
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since of revision 4006 in SVN Trunk, setting links on the tab "External URL" does not work anymore. On trying to set "http://www.google.com/" and hitting the "Set Link" some JavaScript error occurs and the browse link window gets closed without setting the link.

This bug only occurs in Firefox.

With SVN rev. 4005, everything is fine
With SVN rev. 4006 and any later revision, this error occurs.

(issue imported from #M9255)

rtehtmlarea_bugfix_9255_typo3_4-2.patch View (10.3 KB) Administrator Admin, 2008-08-30 01:43

rtehtmlarea_bugfix_9255_trunk.patch View (9.82 KB) Administrator Admin, 2008-08-30 01:54

History

#1 Updated by Uschi Renziehausen about 11 years ago

Hi Stan,

I can reproduce this is issue in a slightly different way after upgrading my core to latest branch of 4.2 this morning but behaviour is somehow different in my installation. This is what happens:

After having entered the URL http://www.tu-ilmenau.de into the URL field I press 'Set Link'. The label of the 'Set Link' button changes shortly to to http://www.tu-ilmenau.de, the link window does not close but the Page tab is activated.

Email links behave the same way.

Kind regards, Uschi

#2 Updated by Johannes Pieper about 11 years ago

I use Firefox 2.0.0.16

I got these JS-Error:

Fehler: uncaught exception: [Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIDOMNSHTMLDocument.execCommand]" nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)" location: "JS frame :: http://localhost/typo3/typo3temp/rtehtmlarea/htmlarea_26010ec2d3539daf3e2e_compressed.js :: anonymous :: line 8" data: no]

#3 Updated by Stanislas Rolland about 11 years ago

Since revision 4006, prototype.ja is included on the page in order to support DAM tabs. prototype.js extends form field elements with a method named setValue. A function with the same name was used by the RTE on the external url and email tabs.

The attached patches fix the issue in trunk and branch TYPO3_4-2 respectively.

#4 Updated by Uschi Renziehausen about 11 years ago

Hi Stan,
patch works like a charm for 4.2 :-)
Uschi

#5 Updated by Stanislas Rolland about 11 years ago

Committed to SVN TYPO3core branch TYPO3_4-2 revision 4038 and trunk revision 4039.

#6 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF