Bug #19467

limit to language not effective in list module

Added by Michael Hirdes almost 13 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-10-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

according to http://typo3.org/documentation/document-library/core-documentation/doc_l10nguide/1.0.0/view/1/4/ ,

"Setting “Limit to languages” is not only good to protect translators from editing other languages or default content - it is also helpful to limit the confusion a user might have when faced with a Web>List display that includes localizations from 10 other languages!"

this is not effective in the list view. (if not checked localization view)

is this a bug in the backend, or a bug in the documentation ?

(issue imported from #M9576)


Files

9576.diff (858 Bytes) 9576.diff Administrator Admin, 2009-01-24 21:22
#1

Updated by Christian Kuhn over 12 years ago

Attached a patch to fix this:

If a user is restricted to some languages only those language records will be shown as records in the list view, except if the record is the default language, or its set to [All] languages.

#2

Updated by Alexander Opitz about 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3

Updated by Alexander Opitz almost 8 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF