Bug #19715

Content-length header is calculated incorrectly

Added by Dmitry Dulepov almost 11 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-12-18
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The method to calculate content length is incorrect. It does not take the following into account:
- admin panel
- debug() statements
- any other output outside of $TSFE->content

(issue imported from #M9972)


Related issues

Related to TYPO3 Core - Bug #15337: Wrong Content-Length header implement in TSFE Closed 2005-12-30
Related to TYPO3 Core - Bug #14922: TYPO3_CONF_VARS['FE']['compressionLevel'] = true leads to no compression with wrong Content-Length Closed 2005-08-11
Related to TYPO3 Core - Bug #20413: wrong content-length header breaks frontend in case of proxy-usage Closed 2009-05-10

History

#1 Updated by Dmitry Dulepov almost 11 years ago

Awaits #19717.

#2 Updated by Alexander Opitz over 6 years ago

  • Category deleted (Communication)
  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3 Updated by Dmitry Dulepov over 6 years ago

  • Status changed from Needs Feedback to Closed
  • TYPO3 Version changed from 4.1 to 6.2

Not relevant any more.

Also available in: Atom PDF