Bug #19726

UTF8 produces bad character output

Added by Thomas Allmer about 12 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2008-12-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

localconf.php
// always use utf-8
$TYPO3_CONF_VARS['BE']['forceCharset'] = 'utf-8';
$TYPO3_CONF_VARS['SYS']['setDBinit'] = 'SET NAMES utf8;';
$TYPO3_CONF_VARS['SYS']['UTF8filesystem'] = 'utf-8';
$TYPO3_CONF_VARS['SYS']['t3lib_cs_convMethod'] = 'mbstring';
$TYPO3_CONF_VARS['SYS']['t3lib_cs_utils'] = 'mbstring';

with this there appear strange chars in the output of the search...

has already been solved in the good old years
http://typo3.toaster-schwerin.de/typo3_english/2007_10/msg00015.html

the line has a little bit shifted but it's still there...
for easy handling here is a patch

(issue imported from #M9989)


Files

UTF8_in_FE.patch (486 Bytes) UTF8_in_FE.patch Administrator Admin, 2008-12-19 22:43

Related issues

Related to TYPO3 Core - Bug #19130: search results too long when non-utf8 characters are in index and iconv is being usedClosed2008-07-21

Actions
Has duplicate TYPO3 Core - Bug #20665: tx_indexedsearch description text with utf-8 encoding issuesClosed2009-06-24

Actions
#1

Updated by Valery Romanchev almost 12 years ago

I can confirm: this problem exists also for Russian.
And the solution works OK.

#2

Updated by Dmitry Dulepov almost 11 years ago

See my comment for #11405

#3

Updated by Alexander Opitz over 7 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.2

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#4

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF