Bug #19798

Cannot Load Multiple RTEs via AJAX

Added by Jeff Segars about 11 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-01-12
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the new frontend editing concept for 4.3, we're loading the RTE via AJAX and displaying it in a lightbox.
On the first load of the RTE, HTMLArea._editorEvent is created as a generic event handler. When the RTE is closed, the HTMLArea.cleanup() method is called to free many variables, including HTMLArea._editorEvent which is set to null. This causes problems with the second RTE load when HTMLArea has already been initialized but _editorEvent is now null rather than a true method.

The solution is to remove the null assignment in HTMLArea.cleanup(). At the same time, the null assignment for HTMLArea.onload can be removed also since it could cause similar issues.

(issue imported from #M10105)

0010105.diff View (567 Bytes) Administrator Admin, 2009-01-12 18:28

History

#1 Updated by Jeff Segars about 11 years ago

Committed to trunk in r4725.

#2 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF