Feature #20119

set more parameters of pi_list_query individually

Added by David Bruchmann over 12 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-03-03
Due date:
% Done:

0%

Estimated time:
PHP Version:
5.2
Tags:
Complexity:
Sprint Focus:

Description

In pi_list_query $pidList is taken from the global conf-array.
Overwriting this Array can be confusing and shouldn't be done because it should be treatend as Array of static values in my opinion.

I'd prefer beeing able to send my own values as parameters in this way:

pi_list_query($table,$count=0,$addWhere='',$mm_cat='',$groupBy='',$orderBy='',$query='',$returnQueryArray=FALSE, $confPidList=$this->conf['pidList'], $confRecursiv=$this->conf['recursive']
...
$pidList = $this->pi_getPidList($confPidList, $confRecursiv);
...

Requirement of my proposition comes from working with different tables.
Alltogether it's possible but not very practicable to change all parameters of pi_base for every table.
(issue imported from #M10589)

#1

Updated by David Bruchmann over 12 years ago

Little Correction:

function pi_list_query($table,$count=0,$addWhere='',$mm_cat='',$groupBy='',$orderBy='',$query='',$returnQueryArray=FALSE, $confPidList='', $confRecursiv='') {

$confPidList = ($confPidList) ? $confPidList : $this->conf['pidList'];
$confRecursiv = ($confRecursiv) ? $confRecursiv : $this->conf['recursive'];
$pidList = $this->pi_getPidList($confPidList, $confRecursiv);
#2

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3

Updated by David Bruchmann over 8 years ago

The function pi_list_query() doesn't exist in the current versions (v4.7.10, v6.1), so this post is obsolete and can be closed.

#4

Updated by Alexander Opitz over 8 years ago

  • Status changed from Needs Feedback to Closed

Closed as commented.

Also available in: Atom PDF