Bug #20178

t3lib_extMgm::addToAllTCAtypes and specific position removes tabs

Added by Michael Stucki about 11 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-03-13
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The following code should add a new field "testfield" right after the hidden field of tt_content:

t3lib_extMgm::addToAllTCAtypes('tt_content','testfield','','after:hidden');

The code will successfully add the new field, however it will remove all tabs after the first two items (e.g. "access" in case of tt_content).

(issue imported from #M10688)


Related issues

Duplicates TYPO3 Core - Bug #19683: Extending palettes and fields to be displayed in back-end forms mixes up tabs Closed 2008-12-04

History

#1 Updated by Michael Stucki about 11 years ago

The reason for the problem is that --div-- and --palette-- fields are allowed multiple times on the same table. However, t3lib_extMgm uses this value as field name at some places.

The bug is fixed by appending a unique number to the field name - and stripping it again when being accessed.

#2 Updated by Michael Stucki about 11 years ago

Actually this is already fixed - I just didn't notice because I'm using a backport of t3lib_extMgm for TYPO3 4.2.

#3 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF