Bug #20610

HMENU does not show top Level Page in TYPO3 v4.3alpha3

Added by David Bruchmann over 12 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-06-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Having a simple HMENU like this:

page.10 = HMENU
page.10 {
1 = TMENU
1.wrap = <div style="width:200px; border: 1px solid;">|</div>
1.expAll = 1
1.NO.allWrap = <b>|</b><br/>
2 = TMENU
2.NO.allWrap = <div style="background:red;">|</div>
}

and a page-structure like this:

root (id=1)
Home (id=2)
Blog-Example (id=3)

page root ( id 1 ) is ignored and only shown when it's called explicitely with another menu-option:

special = directory
special.value = 0

else it's never shown up.

(issue imported from #M11319)

#1

Updated by Susanne Moog over 12 years ago

That's quite normal behavior afaik. 4.2 doesn't behave differently (at least not for me)

#2

Updated by David Bruchmann over 12 years ago

That's right - never remarked that before.
Nevertheless at least special:rootline and special:directory list the first page.
I think behavior is not consistent and has to be at least the same.
For the Bug I described the documentation doesn't say anything about that and the option entryLevel still has the parameter 0 which is useless.
So the behavior seems to be a bug in my eyes even it concerns several versions.

If it's no bug then documentation and special menus and parameters have to be changed.

#3

Updated by Steffen Kamper about 12 years ago

absolotely correct: this worked never before in any version.
Reason: there is at least a pidInList used which contains the pids for the rootline. The rootline, and the root template, never resist in pid=0. So you never get the pages that are in pid=0.

I think this is one of TYPO3 basic which leads to standard page tree constructs: start with a page contain a shortcut to one subpage.

Finally i see no need to change that behaviour.

#4

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF