Bug #20623

content_fallback for whole page, including navigation and title

Added by Albrecht Köhnlein over 12 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-06-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

With TypoScript "config.sys_language_mode = content_fallback ; 1,0" it's possible to define a different fallback language for the content. But I didn't find a way to bring this fallback rule to the navigation or the page title. So my content was english (1) and the navigation and the title were german (0).

I don't know if I was to stupid to find a solution or if there is none. So I just did my first steps in manipulating the core. (see attached file)

It would be great to get some feedback if my patch is useful or if I'm a noob, too stupid to use search functions. ;)

(issue imported from #M11344)


Files

fallback-patch.txt (2.25 KB) fallback-patch.txt Administrator Admin, 2009-06-16 17:57

Related issues

Is duplicate of TYPO3 Core - Bug #17354: fallback for menus. "content_fallback;1,0" has no affect for page records (e.g. menu)Closed2007-07-22

Actions
#1

Updated by Alexander Opitz over 8 years ago

  • Category deleted (Communication)
  • Status changed from Accepted to Closed
  • Target version deleted (0)

Closed as duplicate.

Also available in: Atom PDF