Bug #17354

fallback for menus. "content_fallback;1,0" has no affect for page records (e.g. menu)

Added by Daniel Poetzinger over 11 years ago. Updated 10 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
Start date:
2007-07-22
Due date:
% Done:

90%

Estimated time:
50.00 h
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
nightmare
Is Regression:
No
Sprint Focus:

Description

Problem:
It is not possible to define another that default language as fallback.
This is what TYPO3 does actual:
you can define
config.sys_language_mode=content_fallback;1,0

What this does is to set
$this->sys_language_content in tslib_fe.

So only the content is rendered in a alternative fallback language.

- menues fall back to default
- page title fall back to default

So this is not perfect, cause it makes no sense if menues and pagedata fall back to default but content is shown in another fallback language.

Example:
say you have default=english / 1 = spanish / 2=catalan (spanish language)

typical setting if L=2:
config {
sys_language_uid = 2
sys_language_mode=content_fallback;1,0
}

if you view a page where no catalan version is available TYPO3 shows menu title and pagetitle of defaultlanguage and only the content in spanish.
(What is far from perfect and not the expected behaviour)

Solution:
- It is neccessary that other functions in the core know a fallbackorder.
- especially the function t3lib_page::getPageOverlay needs to know alternative fallback language uids.

I recommend to introduce a new configuration:
config.sys_language_fallBackOrder=1,0
(which is used as general fallbackorder)

Attached a patch with the following changes:
t3lib_page:
1) new function getLanguageOverlayUidForPage($page_id,$fallBackOrder)
(function that checks which page record overlay language should be used, according to the given fallbackorder)
2) adjust getPageOverlay to use fallback uid instead of default

tslib_fe
1) settingLanguage():
set $this->sys_language_overlayCheckOrder
load fallback overlay for actaul page if needed

tslib_menu
1) adjust filterMenuPages to work with the changes

view attached patches
(i use head of branch 4.1)
(issue imported from #M6009)

patch_class.t3lib_page.txt View (3.05 KB) Administrator Admin, 2007-07-22 14:08

patch_class.tslib_fe.txt View (3.13 KB) Administrator Admin, 2007-07-22 14:09

patch_class.tslib_menu.txt View (889 Bytes) Administrator Admin, 2007-07-22 14:09

T3X_danp_languagefallback_patch-0_0_0-z-200708151515.t3x (7.93 KB) Administrator Admin, 2007-08-23 16:14

6009_dmitry.diff View (1.37 KB) Administrator Admin, 2011-03-10 15:35

l10nFallback.patch View (9.66 KB) Stefan Galinski, 2012-03-22 15:10

l10nFallback.patch View (8.71 KB) Stefan Galinski, 2012-03-28 13:30

modifications_6-2-12.txt View (21.3 KB) GRiDDS GmbH, 2016-10-14 13:34

test_modifications_6-2-27.txt View (29.9 KB) GRiDDS GmbH, 2016-10-14 13:34

additional_modification.txt View (1.24 KB) GRiDDS GmbH, 2016-10-14 13:34

BUGFIX-17354-fallback-for-menus-content_fallback-7_6-.patch View (37.9 KB) Nikolaj Wojtkowiak-Pfänder, 2016-11-18 09:23

DifferentLanguageFallbackThenDefaultLanguageForPages.patch View (32.4 KB) Alex Kellner, 2018-10-30 14:48


Related issues

Related to TYPO3 Core - Bug #19114: sys_language_mode content_fallback with a defined fallback chain does not output expected fallback content Resolved 2008-07-16
Related to TYPO3 Core - Bug #19718: Typoscript: CONTENT | slide: multilanguage not correctly respected in content_fallback mode Accepted 2008-12-18
Related to TYPO3 Core - Bug #36616: TYPO3 4.7 sectionIndex not working correctly on multilanguage site Closed 2012-04-26
Related to TYPO3 Core - Bug #48673: Changed language overlay behaviour in TYPO3 6.* Closed 2013-05-30
Related to TYPO3 Core - Bug #53120: Proper fetching of records in a language in the fallback-chain Closed 2013-10-25
Related to TYPO3 Core - Bug #72834: sys_language_mode = content_fallback ; 1,0 is not working with Extbase Closed 2016-01-20
Related to TYPO3 Core - Bug #81657: TSFE->page contains default language page when content_fallback; 1,0 is used Resolved 2017-06-21
Duplicated by TYPO3 Core - Bug #20623: content_fallback for whole page, including navigation and title Closed 2009-06-16
Duplicated by TYPO3 Core - Bug #60052: sys_language_mode=content_fallback only supports language uid 0 as fallback Closed 2014-07-02

History

#1 Updated by Sareen Millet over 11 years ago

I observed the same problem. Then I tried the suggested patches but for me they don't Work. (I use Typo3 Version 4.12)
Has anybody another solution for the problem?

#2 Updated by Daniel Poetzinger over 11 years ago

they should work.

did you set new setting:

config.sys_language_fallBackOrder=1,0

#3 Updated by Sareen Millet over 11 years ago

Hi Daniel,

I used: config.sys_language_mode = content_fallback; 1,0
Why did you change this config to
config.sys_language_fallBackOrder=1,0
I expected the patch to do the same thing as typo3 should do. So I used the normal config.
Now it's working.

Thanks.
Hope this bug is solved in the new Typo3 4.2.0 Version.

greetings

Sareen

#4 Updated by Daniel Poetzinger over 11 years ago

Its because the sematic difference
config.sys_language_mode = content_fallback; 1,0

controls the content fallback, and the fallbackorder is not implemented in a way it could easy be used for a common fallback order.

I my opinion having that common config parameter is more clear. (It changes not only content behaviour - which can also be set to something diffrent than content_fallback - but changes common language fallback)

#5 Updated by Andreas about 11 years ago

thanx daniel!! works perfect. i also think it's better to define the fallback order in an own config property.

#6 Updated by Sareen Millet about 11 years ago

Hi Daniel,

your patch is perfect, thank you. I played around with it for quite some time now.
There remains only one problem with realUrl. The text in the Url still has not the correct language fallBackOrder.
Is there a solution to this?

greetings

Sareen

#7 Updated by Ronald Steiner about 11 years ago

Seams same problem occurs with:
pi_getFFvalue()
- used for FlexForm
Language fallback in steps seams to be quite some problem

#8 Updated by Clemens Riccabona almost 11 years ago

Is this coming up in 4.2? Does anybody know?

#9 Updated by Sonja Schubert over 10 years ago

still not in 4.2.1, please integrate this!

#10 Updated by Daniel Poetzinger over 10 years ago

I will soon publish the extension langaugevisibility which resolves this and a lot more:
http://www.typo3-media.com/extensions/multilanguages-websites-with-typo3-languagevisibility.html

#11 Updated by Jonas Felix over 10 years ago

confirm: the extension works great, we use it in two projects! This has to be integrated into the core!

#12 Updated by Ronald Steiner over 10 years ago

Is this extension for download and test already somewhere?

#13 Updated by Jonas Felix over 10 years ago

@ronald: the extension is attached to this bug report: http://bugs.typo3.org/file_download.php?file_id=2929&type=bug

#14 Updated by Ronald Steiner over 10 years ago

as far as I see, this is "just" the bugfix. And there will be an huge extension "languagevisibility" that solves this bug and adds a lot of features.

#15 Updated by Jonas Felix over 10 years ago

but shouldn't such thing be integrated in the core?

I'm realy carefull with such core changing extensions, they can lead to other problems. Is it tested with TV, Workspaces and all the other needed TYPO3 things?

#16 Updated by Daniel Poetzinger over 10 years ago

sure its tested with workspaces / templavoila / even introduce new templavoila features

the extension is availabe at forge: http://forge.typo3.org/projects/show/extension-languagevisibility

sildes:
http://www.typo3-media.com/extensions/multilanguages-websites-with-typo3-languagevisibility.html

#17 Updated by Andreas over 10 years ago

thanx!! works like a charm!

#18 Updated by Ronald Steiner over 10 years ago

Hi Daniel,

I just test your extension: languagevisability
- it seems to work fine so far, but the bug described here is not resolved, is it? Or is there a special TypoScript Configuration necessary to resolve this bug?

And it seems not possible to install that extension together with the patch you proviede here: T3X_danp_languagefallback_patch-0_0_0-z-200708151515.t3x

Schould this patch not be integrated in your extension languagevisability? Am I getting something wrong?

greetings

Ron

#19 Updated by Ronald Steiner over 10 years ago

P.S.: For me correct language fallback in menu's is more important, so I now only use the patch and not the extension.

#20 Updated by Michael Stucki almost 10 years ago

Daniel, can you update the patch for TYPO3 4.2 please? Additionally, please check my patch in #19114.
It seems to work quite different than the solution that you have come to. What it basically does is the provide content-fallback even if the page record has been translated, but not all content on it.

Any feedback is appreciated.

- michael

#21 Updated by Jonas Felix over 9 years ago

It would be great if somebody could writhe a manual on how to implement translation handling for records in extensions. But a way which supports the full features of translation handling in TYPO3.

Is this integrated in the ExtBase persitence layer?

#22 Updated by Dmitry Dulepov about 8 years ago

I attach another patch, which fixes everything.

According to the docs menu and page title should be translated as well when content_fallback is in use. This means that the page record and $TSFE->sys_language_uid should be set to a fallback language. Indirectly this is confirmed by TSRef in the description of sys_language_uid:

<blockquote>Internally, the value is depending on whether a Alternative Page Language record can be found with that language. If not, the value will default to zero (default language) except if “sys_language_mode” is set to a value like “content_fallback”.</blockquote>

and

<blockquote>The system will always operate with the selected language even if the page is not translated with a page overlay record. This will keep menus etc. translated</blockquote>

So the patch checks if the fallback is set and changes page record and sys_language_uid to be the one from fallback, which makes the behavior identical to described in TSRef.

Result: menu in the fallback language, page title in the fallback language, links still stay with user's choosen language.

One possible drawback could be with language selectors. If they use $TSFE->sys_language_uid, they will show a fallback language. Instead they should use the value of "L".

#23 Updated by Juergen Weber almost 8 years ago

  • Target version deleted (0)

I have this issue in TYPO3 version 4.5. Isn't this fixed yet? Dimitry, will your patch also work with 4.5?

#24 Updated by amareco almost 8 years ago

The problem is´nt fixed in Typo3 4.5.2 but the patch works there.

#25 Updated by Philipp Idler almost 8 years ago

amareco wrote:

The problem is´nt fixed in Typo3 4.5.2 but the patch works there.

what patch? dmitry's?
doesn't work for me (4.5.3)

i don't understand why this isn't part of the core...

#26 Updated by Evgeniy Martynov almost 8 years ago

Hi,

Dmitry Dulepov wrote:

I attach another patch, which fixes everything.
...

I checked both solutions.

While danp_languagefallback_patch adrresses the issue the patch from Dmitrij does not at all.

The main problem is not translation of the currently selected page record (while in content_fallback mode), but rather falling back while translating menu items for other pages which are present in the menu.

Dmitrij's patch works only with currently selected page, while danp_languagefallback_patch reimplements getPageOverlay which actually provides menu biulding class with translated page records.

#27 Updated by Dmitry Dulepov about 7 years ago

  • Category deleted (Communication)

Dan's patch is incorrect because it adds a dependency from t3lib_page to TSFE. This should not happen. There must be a different solution.

#28 Updated by Henrik Ziegenhain almost 7 years ago

Any news on this issue?
It`s still reproducable in 4.6.6

#29 Updated by Stefan Galinski almost 7 years ago

I have written a small patch for the site [[http://www.ashtangayoga.info/]] last week that consideres the configured content_fallback setting for pages too. Furthermore it introduces a new API method to overlay other non-page records with a possible fallback, but you must modify the necessary extensions yourself. It's already done for the core and so that stuff should already work in most cases. Just have a look at the patch for more details. Feedback is welcome and maybe this simple patch or a modification of it can be submitted to Gerrit sooner or later.

#30 Updated by Henrik Ziegenhain almost 7 years ago

Hi Stefan,

meanwhile I tested Dmitrys patch - It solves the main problem with non translated navigations, but there are strange side effects I can`t discribe.
I will give your patch shortly a try - would be great to see this in core.

#31 Updated by Henrik Ziegenhain almost 7 years ago

Hi Stefan,

I set up an test installation and imported my site (12 Languages!).
Everything is working as expected after applying your patch.

From my humble point of view you maybe could submit it to Gerrit.

PS: I think this is also related to #20623

#32 Updated by Stefan Galinski almost 7 years ago

  • Status changed from New to Accepted
  • Assignee set to Stefan Galinski

Hi Henrik,

I marked #20623 as a duplicate of this one and will submit the patch to Gerrit for 4.8 only (and 4.5/4.6 backports afterwards if Ernesto/Xavier want it) in some days to get some more feedback and practical results as the patch is already running in a live installation. Thanks for your review! :-)

#33 Updated by Stefan Galinski almost 7 years ago

Hi Henrik,

I fixed a possible edge-case in the patch and will upload this to one to Gerrit now. Please review it again carefully, just to be sure that nothing else slipped in and don't forget voting in Gerrit. Thanks in advance! :-)

Edit: Everyone and not just Hendrik is invited to do the same. ;-)

#34 Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#35 Updated by Henrik Ziegenhain almost 7 years ago

Thanks Stefan,

+1 by reading - Is there a way to download the changes as patch-file to apply it to my local installation?
I did not really deal with the new review system before. Sorry.

After a short test I will give my vote in Gerrit.

#36 Updated by Stefan Galinski almost 7 years ago

I attached the new version of the patch directly taken from Gerrit by using the patch command. To get such a patch by yourself, you just need to clone the git repository of TYPO3 and execute one of the mentioned commands below a patchset in Gerrit on the sources.

#37 Updated by Stefan Galinski almost 7 years ago

  • % Done changed from 0 to 90
  • Estimated time set to 50.00 h
  • Complexity set to nightmare

#38 Updated by Daniel Poetzinger almost 7 years ago

Why not using languagevisibility? :-) Its all working there and a lot of more things..

Just my 2 cents :-)

#39 Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#40 Updated by Stefan Galinski almost 7 years ago

Hi Daniel,

Your extension does lot's of more stuff and that's exactly the problem. Also I didn't understood the code and it didn't worked for me like I had expected it (just install it, define the fallback order and go).

#41 Updated by Gerrit Code Review almost 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#42 Updated by Henrik Ziegenhain almost 7 years ago

Push :)

Stefan and Ronald, could you please also look at the new patch from Markus?

#43 Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#44 Updated by Stefan Regniet over 6 years ago

Hi together. Just tested the patch on a page with > 40 languages (on a patched 4.7.2). Works fine so far.
But it seems that it ignores l18n_cfg setting (2) in page-record (Hide page if no translation is available).
So I don't have any chance to explicitly hide certain pages that I don't want to show in fallback.

That one should be patched in t3lib_page imho... Thanks :)

#45 Updated by Stefan Galinski over 6 years ago

Really? This setting works for me!? Please test the latest version of the patch. Will be there in a few minutes... :-)

#46 Updated by Gerrit Code Review over 6 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#47 Updated by Gerrit Code Review over 6 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#48 Updated by Gerrit Code Review over 6 years ago

Patch set 7 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#49 Updated by Gerrit Code Review over 6 years ago

Patch set 8 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#50 Updated by Gerrit Code Review over 6 years ago

Patch set 9 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#51 Updated by Gerrit Code Review over 6 years ago

Patch set 10 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#52 Updated by Gerrit Code Review over 6 years ago

Patch set 11 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#53 Updated by Gerrit Code Review over 6 years ago

Patch set 12 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#54 Updated by Gerrit Code Review over 6 years ago

Patch set 13 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#55 Updated by Gerrit Code Review over 6 years ago

Patch set 14 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9937

#56 Updated by Camelia M about 6 years ago

It seems to me this is a bug in typo3 6.0 also

#57 Updated by Gerrit Code Review about 6 years ago

Patch set 15 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9937

#58 Updated by Gerrit Code Review about 6 years ago

Patch set 16 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9937

#59 Updated by Camelia M about 6 years ago

Patch 16 seems to work fine for me. Thank you

#60 Updated by Camelia M about 6 years ago

Camelia M wrote:

Patch 16 seems to work fine for me. Thank you

Actually, after I apply this patch, localizations for jfmulticontent stop working. Not sure if this is the only one that stops working, but this is the first I noticed.

#61 Updated by Camelia M almost 6 years ago

Camelia M wrote:

Camelia M wrote:

Patch 16 seems to work fine for me. Thank you

Actually, after I apply this patch, localizations for jfmulticontent stop working. Not sure if this is the only one that stops working, but this is the first I noticed.

I forgot to mention that I did replace getRecordOverlay function call with getRecordOverlayWithFallback

#62 Updated by Gerrit Code Review almost 6 years ago

Patch set 17 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9937

#63 Updated by Gerrit Code Review almost 6 years ago

Patch set 18 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9937

#64 Updated by Gerrit Code Review almost 6 years ago

Patch set 19 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9937

#65 Updated by Gerrit Code Review over 5 years ago

Patch set 20 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9937

#66 Updated by Gerrit Code Review over 5 years ago

Patch set 21 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9937

#67 Updated by Stefan Galinski over 5 years ago

  • Assignee deleted (Stefan Galinski)
  • Is Regression set to No

#68 Updated by Marius S. over 5 years ago

Has anyone a patch for TYPO3 6.0.4? Patch set 21 isn't working in this version.

#69 Updated by Marc Steiner over 4 years ago

Stefan Regniet wrote:

Hi together. Just tested the patch on a page with > 40 languages (on a patched 4.7.2). Works fine so far.
But it seems that it ignores l18n_cfg setting (2) in page-record (Hide page if no translation is available).
So I don't have any chance to explicitly hide certain pages that I don't want to show in fallback.

That one should be patched in t3lib_page imho... Thanks :)

Hi all,
we applied the patch set 21 to our 6.2 installation, but we also had the problem, that it ignores the l18n_cfg setting as mentioned above.

To fix this(at least for the basic HMENU) we changed line number 975 in the file typo3/sysext/frontend/Classes/ContentObject/Menu/AbstractMenuContentObject.php.

In function filterMenuPages after:

if ($GLOBALS['TSFE']->sys_language_uid && GeneralUtility::hideIfNotTranslated($data['l18n_cfg'])) {

-       if (!$data['_PAGES_OVERLAY']) {
+       if (!$data['_PAGES_OVERLAY'] || ($data['_PAGES_OVERLAY_LANGUAGE'] != $data['sys_language_uid'])) {

#70 Updated by Wolfgang Hamster over 4 years ago

why this bug isn't resolved in typo3 6.2 yet?
is there any extension to fix it?

#71 Updated by Stefan Neufeind over 4 years ago

There is a patch under review. Maybe that works for you? But it was mentioned in the review that somebody still had an issue with it. And currently it seems to be handled as a "feature" (won't have this for 6.2 then unfortunately) and not as a bugfix.

#72 Updated by Gerrit Code Review over 4 years ago

Patch set 22 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/9937

#73 Updated by Gerrit Code Review over 4 years ago

Patch set 23 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/9937

#74 Updated by Marc Hirdes over 4 years ago

So ist there any current workaround for TYPO3 6.2?

#75 Updated by Stefan Galinski over 4 years ago

Not really, but you can apply the patch yourself in 6.2 if you know how to do that. AFAIK there are not many differences, so you shouldn't get any errors.

#76 Updated by Marc Hirdes over 4 years ago

But then I can't update the core when a new minor-version is published. Aren't there any other solutions? Isn't there any bugfix for 6.2?

#77 Updated by Mathias Brodala over 4 years ago

Marc Hirdes wrote:

But then I can't update the core when a new minor-version is published.

You can always re-apply the patch on update. In case you are using Composer the composer-patches-plugin might prove useful here.

Aren't there any other solutions? Isn't there any bugfix for 6.2?

Since the change has not been merged yet, there cannot be a bugfix release including it.

#78 Updated by Marc Hirdes over 4 years ago

I don't use composer. For my local distribution it is only possible to set all changes manually in files?

Is it possible, that the next bugfix release include it?

#79 Updated by Mathias Brodala over 4 years ago

Marc Hirdes wrote:

I don't use composer. For my local distribution it is only possible to set all changes manually in files?

Not necessarily if you use the patch command. :-)

#80 Updated by Marc Hirdes over 4 years ago

OK I used the patch command. First it looks ok. But RealURL returns also a bad URL and another Extension provides also the wrong title. In this https://forge.typo3.org/issues/18062 Issu is said, that RealURL expects the correct Lang-Param from core.

Am I the only one with this problem? I meen in many multilanguage pages I think they would have different fallbacks for different languages (austria -> german, us -> uk etc.).

Are there experiences with other extensions? And will this patch include in the Core maybe? Thanks a lot for support.

#81 Updated by Stefan Galinski over 4 years ago

I found a fix, but realurl can't handle the resulting urls with fallback names inside them. The root cause is that sometimes getPageOverlay is called with an explicit language parameter and this means to the function that the user want's exactly this language. Changing this behaviour will automatically be a breaking change.

#82 Updated by Gerrit Code Review over 4 years ago

Patch set 24 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/9937

#83 Updated by Marc Hirdes over 4 years ago

To handle RealUrl I translated every page. So the title of the page is correct and also the URL. My last problem is with Gridelemnts. When I have an element inside of antother element the fallback is the default language. Other elements are shown correct in the fallback language.

#84 Updated by Marc Hirdes over 4 years ago

OK, when I change in Gridelements.php line 161 getRecordOverlay to getRecordOverlayWithFallback it works fine.

$child = $GLOBALS['TSFE']->sys_page->getRecordOverlayWithFallback('tt_content', $child, $GLOBALS['TSFE']->sys_language_content, $GLOBALS['TSFE']->sys_language_contentOL);

Maybe the funtion getRecordOverlay can allways get the fallback, if no translation is given?

#85 Updated by Gerrit Code Review over 4 years ago

Patch set 25 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/9937

#86 Updated by Gerrit Code Review over 4 years ago

Patch set 26 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/9937

#87 Updated by Gerrit Code Review over 4 years ago

Patch set 27 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/9937

#88 Updated by Gerrit Code Review about 4 years ago

Patch set 28 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/9937

#89 Updated by Gerrit Code Review over 3 years ago

Patch set 29 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/9937

#90 Updated by Gerrit Code Review over 3 years ago

Patch set 30 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/9937

#91 Updated by Gerrit Code Review over 3 years ago

Patch set 31 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/9937

#92 Updated by Markus Klein over 3 years ago

  • Category set to Frontend
  • Assignee set to Markus Klein
  • PHP Version deleted (4.3)
  • Sprint Focus set to Remote Sprint

#93 Updated by Alexander Opitz over 3 years ago

  • Target version set to 8 LTS

#94 Updated by Markus Klein about 3 years ago

  • Assignee deleted (Markus Klein)
  • Sprint Focus deleted (Remote Sprint)

#95 Updated by GRiDDS GmbH over 2 years ago

We experienced confusing behavior with language handling as well. We collected and refined patches from different sources and now we have a system that works for us. We have tried this with TYPO3 6.2.12, 6.2.15 and 6.2.27 (I have attached the changes to TYPO3 6.2.12 and 6.2.27).

Use config.languageFallbackChain in the TS setup (f.e. config.languageFallbackChain = 2)

We are not sure, if our patch fixes all the mentoined requirements, but it solves our problems with ts-menues and content elements (also of several plugins) with the language-fallback problems

If anyone is interested in the full modified TYPO3 6.2.15 or 6.2.27 core, write to (free, no support).

#96 Updated by Nikolaj Wojtkowiak-Pfänder over 2 years ago

We modified the last patch (patch set31) to work with TYPO3 7.6.13. Not definitely sure, if all problems are fixed, but it seems to work on our system.

#97 Updated by Henrik Ziegenhain over 2 years ago

I will give it a try maybe tomorrow. This bug is so annoying and needs to be addressed and tested to find its way to 8!
Thanks for your patch, Nikolaj.

#98 Updated by Henrik Ziegenhain over 2 years ago

YES. Patch is working for us also in two 7-LTS-instances.

Nicolaj, can you push it please to gerrit?

#99 Updated by Susanne Moog over 2 years ago

  • Category changed from Frontend to Localization
  • Status changed from Under Review to Accepted

This issue is valid but the current pending patch hasn't be touched in a long time and isn't going to get merged. That's why I'm changing the issue state back to accepted. This issue has to be part of our broader review of localization / language handling in TYPO3 which is why I changed the category.

#100 Updated by Christian Kuhn over 2 years ago

  • Status changed from Accepted to New

#101 Updated by Benni Mack almost 2 years ago

  • Target version changed from 8 LTS to next-patchlevel

#102 Updated by Benni Mack over 1 year ago

  • Related to Bug #81657: TSFE->page contains default language page when content_fallback; 1,0 is used added

#103 Updated by Sebastian Schmal about 1 year ago

the menu dont works for sys_language_mode = content_fallback; 1 in TYPO3 8.7.10
AFTER 10 years :D

#104 Updated by Begovic Malik 11 months ago

Im also having this problem with 8.7.13, any help?

#105 Updated by Alex Kellner 5 months ago

Same here in 8.7.19. content_fallback has no influence on pages

#106 Updated by Alex Kellner 5 months ago

Thank you all for your work.
Here is the patch for TYPO3 8.7 (tested on 8.7.19 and .20)


Still needs the TypoScript configuration (as mentioned above):

config.languageFallbackChain =


Could be used together with package "cweagans/composer-patches" https://typo3worx.eu/2017/08/patch-typo3-using-composer/

#107 Updated by Mathias Brodala 5 months ago

Alex Kellner wrote:

Thank you all for your work.
Here is the patch for TYPO3 8.7 (tested on 8.7.19 and .20)

Can you post this to our review system please? See the Contribution Guide for details.

#108 Updated by Benni Mack 10 days ago

  • Status changed from New to Resolved

This is now finally fixed in TYPO3 v9.5.5 - multi-level fallback chains for pages/menu/urls is implemented!

Also available in: Atom PDF