Bug #20706

Russian chars in the comments are encoded wrong when changing the stage of an element

Added by Marco Huber over 10 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Category:
Workspaces
Target version:
-
Start date:
2009-07-01
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the Versioning-Modul:
When you change the stage for an element, for example sending it to the reviewer, a javascript popup box opens where you can enter a comment. When you enter russian chars they aren't stored correct. This is because the comment is sended through the javascript function escape().
The better way is to send it through encodeURI(), or perhaps through encodeURIComponent().
So you have to replace the string escape(commentTxt) with encodeURI(commentTxt) in the file typo3/sysext/version/cm1/index.php. You'll find it three times in this files.
Perhaps there are some more files where you have to replace it. Until now I only found this one.
It would be nice if this little change would find its way to the next TYPO3-Versions... ;-)

(issue imported from #M11458)

11458.diff View (1.74 KB) Administrator Admin, 2009-07-15 17:04

ver_escape.png View (30.4 KB) Administrator Admin, 2009-07-15 17:04


Related issues

Duplicated by TYPO3 Core - Bug #21002: message to reviewer has troubles with umlauts Closed 2009-09-05

History

#1 Updated by Steffen Kamper over 10 years ago

please tell me your charset settings

#2 Updated by Administrator Admin over 10 years ago

in the database everything is in utf-8 (DEFAULT TABLE CHARSET, COLLATION, ...).
In the Install-tool / localconf.php:
$TYPO3_CONF_VARS['SYS']['setDBinit'] = 'SET NAMES utf8';
$TYPO3_CONF_VARS['BE']['forceCharset'] = 'utf-8';

Anything else you want to know?

P.S.: I got the information mail that you have added your note today (14.07.2009) but you added your note two weeks before. is this normal?

#3 Updated by Steffen Kamper over 10 years ago

it's because the server moved.

#4 Updated by Tolleiv Nietsch about 8 years ago

  • Status changed from Accepted to Closed
  • Target version deleted (0)

Assuming this is outdated ... feel free to reopen if my assumption was wrong

#5 Updated by Michael Stucki almost 6 years ago

  • Category set to Workspaces

#6 Updated by Michael Stucki almost 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

Also available in: Atom PDF