Bug #20793

noTrimWrap = | || won't work inside a menu

Added by Christian Zenker almost 12 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
Start date:
2009-07-29
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

TYPO3 seems to recognize this pattern as an optionSplit inside a HMENU...

10 = HMENU
10 {
1 = TMENU
1 {
ATagParams.cObject = COA
ATagParams.cObject {
wrap = class="|"
10 = TEXT
10.value = menu
20 = TEXT
20 {
value = highlight
noTrimWrap = | ||
fieldRequired = ...
}
}
}
}

should also be present in lower versions of TYPO3:
compare:
http://www.typo3.net/index.php?id=13&action=list_post&tid=79003 [de]

(issue imported from #M11598)


Related issues

Related to TYPO3 Core - Bug #67669: noTrimWrap not working with optionSplitNew2015-06-22

Actions
#1

Updated by Jochen Rau over 9 years ago

  • Category set to TypoScript
  • Status changed from New to Accepted
  • Target version deleted (0)
  • TYPO3 Version changed from 4.3 to 4.7
  • PHP Version changed from 4.3 to 5.3

I can confirm this issue using the following setup:

temp.mainMenu.10 = HMENU
temp.mainMenu.10 {
  entryLevel = 0
  1 = GMENU
  1.expAll = 1
  1.wrap = <ul class="firstLevel">|</ul>
  1.NO = 1
  1.NO {
    allWrap = <li>|</li>
    XY = [10.w]+10,[10.h]+10
    backColor = #ffffff
    transparentColor = #ffffff
    transparentBackground = 1
    10 = TEXT
    10 {
      text.field = title
      text.noTrimWrap = | -- | |
      fontSize = 14px
      fontFile = fileadmin/fonts/momstypewriter.ttf
      fontColor = #535f5f
      offset = 0,26
    }
  }
  1.ACT < .1.NO
  1.ACT {
    allWrap = <li class="current">|</li>
  }
}
#2

Updated by Jochen Rau over 9 years ago

  • Assignee set to Jochen Rau

The issue is caused by the implementation of the optionSplit. Specifically by an explode pattern '||' used in t3lib_TStemplate::splitConfArray. This pattern can also occur in a noTrimWrap wit different semantics.

#3

Updated by Jochen Rau over 9 years ago

  • Status changed from Accepted to Under Review
#4

Updated by Steffen Ritter over 9 years ago

  • Target version set to 4.7.0-beta2
#5

Updated by Steffen Ritter over 9 years ago

  • Status changed from Under Review to Accepted
#6

Updated by Steffen Ritter over 9 years ago

  • Assignee deleted (Jochen Rau)
#7

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9428

#8

Updated by Steffen Ritter over 9 years ago

  • Target version changed from 4.7.0-beta2 to 4.7.0-beta3
#9

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7255

#10

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9428

#11

Updated by Gerrit Code Review over 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9428

#12

Updated by Gerrit Code Review over 8 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9428

#13

Updated by Gerrit Code Review over 8 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9428

#14

Updated by Gerrit Code Review over 8 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9428

#15

Updated by Gerrit Code Review over 8 years ago

Patch set 7 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9428

#16

Updated by Jigal van Hemert over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#17

Updated by Chris topher about 8 years ago

  • Target version changed from 4.7.0-beta3 to 6.1.0
#18

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF