Bug #20978

Integrate possiblity to extend static classes like t3lib_div

Added by Oliver Hader over 10 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-09-02
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Static classes like t3lib_div lack of the possibility to be extended as know from the XCLASS notation. However, this won't work for static classes since no object is generated.

Possible tasks:
  • get rid of the "final class" statement
  • convert static classes to singletons and change the accordant code
  • think about an API to define static classes to be extensible

(issue imported from #M11851)


Related issues

Related to TYPO3 Core - Bug #20964: Remove final from classes Closed 2009-08-31

History

#1 Updated by Xavier Perseguers over 8 years ago

  • Target version deleted (4.6.0-beta1)

#2 Updated by Mathias Schreiber about 5 years ago

  • Status changed from New to Closed
  • Is Regression set to No

Also available in: Atom PDF