Bug #21173

Replace "Warning: filemtime(): stat failed" with a nice error message

Added by Steffen Gebert over 12 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-10-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If a file in uploads/ folder is missing, but referenced in a content element
a) PHP warning appears (and may break layout), if display_errors is enabled
b) no hint is given to the user

So add a check, weather the file really exists and output a warning otherwise.

(issue imported from #M12099)


Files

12099.diff (2.11 KB) 12099.diff Administrator Admin, 2009-10-01 22:42
before.png (3.44 KB) before.png Administrator Admin, 2009-10-01 22:43
after.png (3.35 KB) after.png Administrator Admin, 2009-10-01 22:43
12099_v2.diff (2.05 KB) 12099_v2.diff Administrator Admin, 2009-11-17 19:54

Related issues

Related to TYPO3 Core - Bug #17321: filemtime() [function.filemtime]: stat failedClosed2007-05-22

Actions
Related to TYPO3 Core - Bug #19716: History/Undo not works on image elementsClosed2008-12-18

Actions
#1

Updated by Ralf Hettinger over 12 years ago

this is a duplicate of #17321.
t3lib_FlashMessage? nice :)

#2

Updated by Rupert Germann about 12 years ago

committed v2 to trunk rev 6459

Also available in: Atom PDF