Bug #19716

History/Undo not works on image elements

Added by Robert Heel almost 13 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-12-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you delete an image in an image element (not the content element) and undo this with the History/Undo function, the image is not restored and a error message appears:

Warning: filemtime() [function.filemtime]: stat failed for /var/www/uploads/pics/... in /usr/share/typo3/typo3_src-4.3.0alpha1/t3lib/class.t3lib_befunc.php on line 1729

When deleting an image typo3 delete the copy in /uploads/pics, but on undo it don't restore/recreate this file.

(issue imported from #M9973)


Files

typo3_43b1_bug.PNG (41.9 KB) typo3_43b1_bug.PNG Administrator Admin, 2009-10-15 13:19

Related issues

Related to TYPO3 Core - Bug #17079: Wrong path for images in repetitive content elementsClosed2007-03-05

Actions
Related to TYPO3 Core - Bug #17321: filemtime() [function.filemtime]: stat failedClosed2007-05-22

Actions
Related to TYPO3 Core - Bug #21173: Replace "Warning: filemtime(): stat failed" with a nice error messageClosedRupert Germann2009-10-01

Actions
#1

Updated by Staffan Ericsson about 12 years ago

A display of the bug is uploaded in the typo3_43b1_bug.PNG file.

It's really annoying and I would say it the error handling should be less intrusive.

#2

Updated by Ralf Hettinger about 12 years ago

related to #M5132 #M5665 and #M12099

#3

Updated by Susanne Moog over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Target version deleted (0)
#4

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Needs Feedback

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#5

Updated by Alexander Opitz about 8 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF