Bug #21439

explaining comments for loadTCA are confusing

Added by Stefan Froemken over 11 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-11-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Let's have a look into the comment of class.t3lib_div.php::loadTCA():
"Note: For the frontend this loads only 'ctrl' and 'feInterface' parts."
But three rows later you find this one:
"Table name for which to load the full TCA array part into the global $TCA"

In first part you told, that only ctrl and feInterface will be loaded, but later you told us that ALL will be loaded.

Next:

Let's have a look into the comment of class.tslib_fe.php::includeTCA():
"To load full TCA for the table, use t3lib_div::loadTCA($tableName) after calling this function."

Why I have to load TCA twice. I just programmed three lines WITHOUT loadTCA and ALL additional columns will be showed:

$GLOBALS['TSFE']->includeTCA();
$fe_users = $GLOBALS['TCA']['fe_users'];
print_r($fe_users);

(issue imported from #M12446)

#1

Updated by Alexander Opitz about 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 4.7)?

BTW. Deprecated since 6.1

#2

Updated by Stefan Froemken about 8 years ago

Hello Alexander,

this issue is only a translation problem. You wrote in the comment of loadTCA:

Note: For the frontend this loads only 'ctrl' and 'feInterface' parts.

The word "this" is confusing, because "this" sounds like "this method (loadTCA) loads only ctrl and feInterface". But that is wrong. Maybe it should be:

Note: For the frontend only 'ctrl' and 'feInterface' parts were loaded (automatically). Please use this function to load the "columns" part also.

Stefan

#3

Updated by Alexander Opitz about 8 years ago

  • Status changed from Needs Feedback to Accepted
#4

Updated by Christian Kuhn over 6 years ago

  • Status changed from Accepted to Rejected
  • Is Regression set to No

While this method still exists in 6.2, it was removed for 7. I don't think it makes much sense to still improve this comment in 6.2 and would like to close this issue as rejected. Hope everyone is fine with that.

Also available in: Atom PDF