Bug #21481

Backend: Generated tumbnails can't cached in the clients browser

Added by Michael Klapper over 11 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2009-11-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
Thumbnails can not be cached by browser.

There is always the current timestamp appended to the thumbnail URL, IMHO that is not required because the thumbnails URL contains already a check sum ("t3lib_div::shortMD5()") based on the:
- $GLOBALS['TYPO3_CONF_VARS']['SYS']['encryptionKey']
- filename
- filetime

Solution:
- Remove the parameter "dummy=timestamp" from the URL
- The used md5 should be enlarged to full 32 char.

Note:
The tumbnails are cached well in the "typo3temp/" folder, that is based on an md5 sum.

The generated URL look like:
typo3/thumbs.php?&file=__ABSOLUTE_PATH_TO_FILE__&size=56x56&md5sum=d509bbc84d&dummy=1257502882

Global variable is set to the current time stamp:
typo3_src/t3lib/config_default.php:484:$EXEC_TIME = time();

Used: =======================
t3lib/class.t3lib_befunc.php:1808: $url = $thumbScript.'?&dummy='.$GLOBALS['EXEC_TIME'].$params;
t3lib/class.t3lib_befunc.php:1837: $url = $thumbScript.'?&dummy='.$GLOBALS['EXEC_TIME'].$params;

ypo3/sysext/cms/tslib/class.tslib_content.php:4619: $icon = 't3lib/thumbs.php?dummy='.$GLOBALS['EXEC_TIME'].'&file='.rawurlencode('../'.$theFile).$thumbSize.$md5sum;

typo3/show_item.php:427: $url = $thumbScript.'?&dummy='.$GLOBALS['EXEC_TIME'].$params;
typo3/class.file_list.inc:536: $href = $this->backPath.$this->thumbScript.'?&dummy='.$GLOBALS['EXEC_TIME'].$params;

And a lot of more .....
(issue imported from #M12490)


Related issues

Related to TYPO3 Core - Feature #19713: Cache thumbnails shown in element browserClosed2008-12-18

Actions
#1

Updated by Mr. Jenkins over 9 years ago

  • Status changed from New to Under Review

Patch set 1 of change I852e6d8c4a2626c167fa4ea380874b46f17112ca has been pushed to the review server.
It is available at http://review.typo3.org/6876

#2

Updated by Gerrit Code Review about 9 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/6876

#3

Updated by Dmitry Dulepov about 9 years ago

  • Target version deleted (0)

I abandoned my change in Gerrit because once again it went from review of the real fix to an abstract discussion and -1s based on that. Let somebody else fix bugs in the environment like this...

#4

Updated by Dmitry Dulepov about 9 years ago

  • Status changed from Under Review to New
#5

Updated by Dmitry Dulepov about 9 years ago

  • Status changed from New to Accepted
#6

Updated by Gerrit Code Review about 9 years ago

  • Status changed from Accepted to Under Review

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/6876

#7

Updated by Gerrit Code Review about 9 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/6876

#8

Updated by Gerrit Code Review about 9 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/6876

#9

Updated by Gerrit Code Review about 9 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/6876

#10

Updated by Gerrit Code Review about 9 years ago

Patch set 7 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/6876

#11

Updated by Gerrit Code Review about 9 years ago

Patch set 8 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/6876

#12

Updated by Dmitry Dulepov almost 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#13

Updated by Gerrit Code Review almost 9 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/9471

#14

Updated by Dmitry Dulepov almost 9 years ago

  • Status changed from Under Review to Resolved
#15

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/12819

#16

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/12820

#17

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/12819

#18

Updated by Dmitry Dulepov over 8 years ago

  • Status changed from Under Review to Resolved
#19

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF