Bug #21484

OpenID service modifies PHP include path what has negative impact on autoloader

Added by Oliver Hader about 10 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-11-06
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The method tx_openid_sv1::includePHPOpenIDLibrary() modifies the PHP include path. Thus, functionalities that are addressed there in OpenID cannot make proper use of the autoloader (e.g. this also effects error handling and reporting).

Can be easily reproduced with PHP 5.3 since the OpenID lib uses some "old-school" PHP style that won't work in PHP 5.3 anymore and would trigger the TYPO3 eror/exception handler.
(issue imported from #M12494)

History

#1 Updated by Dmitry Dulepov about 10 years ago

Bug report does not contain details -> impossible to fix :( There should be a list of problems (like "PHP error XYZ" or "false exception thrown when..."). Until that, this bug report cannot be solved.

#2 Updated by Tolleiv Nietsch over 8 years ago

  • Assignee set to Oliver Hader
  • Target version deleted (0)

Olly any update?

#3 Updated by Dmitry Dulepov about 8 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Oliver Hader)

No feedback provided. OpenID works in every installation that I use (hundreds!).

Also available in: Atom PDF