Bug #21647

OpenID redirects to wrong page and does not create a BE session

Added by Steffen Müller almost 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Must have
Category:
-
Target version:
-
Start date:
2009-11-23
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since rev. 6451 the OpenID login does not work for me.

I end up at http://www.example.com/typo3/sysext/openid/ instead of the backend.
No BE session is created.

When I switch back to rev. 6451 everything works fine.

After entering the OpenID in the TYPO3 login box, I get redirected to the OpenID provider. So far it works. But after login at the OpenID provider, I get redirected to http://www.example.com/typo3/sysext/openid/ instead of the TYPO3 backend. Also there is no valid BE session created.

I am using a Lanchpad account as OpenID account: https://login.launchpad.net/
(issue imported from #M12706)

bug_12706.diff View (767 Bytes) Administrator Admin, 2009-11-24 11:51


Related issues

Related to TYPO3 Core - Bug #21444: OpenID authentication does not work with PHP 5.3 Closed 2009-11-03

History

#1 Updated by Steffen Müller almost 10 years ago

Appended file is a recording of the HTTP traffic. The TYPO3 host was a local installation: http://lenny.test

#2 Updated by Francois Suter almost 10 years ago

I have the same problem.

Firefox 3 on Mac, provider is openid.com.

#3 Updated by Steffen Müller almost 10 years ago

I have found the reason for this. The openid service class uses a wrong constant PATH_SEPARATOR:
Line 325 of openid/sv1/class.tx_openid_sv1.php

$openIDStorePath = PATH_site . 'typo3temp' . PATH_SEPARATOR . 'tx_openid';
This results in .../typo3temp:tx_openid

Solution: DIRECTORY_SEPARATOR should be used instead of PATH_SEPARATOR

$openIDStorePath = PATH_site . 'typo3temp' . DIRECTORY_SEPARATOR . 'tx_openid';
This correctly results in .../typo3temp/tx_openid

#4 Updated by Steffen Müller almost 10 years ago

appended patch fixes the issue

#5 Updated by Rupert Germann almost 10 years ago

committed to trunk rev 6509

Also available in: Atom PDF