Bug #21724

Local reverse proxy disables ENABLE_INSTALL_TOOL check

Added by Dan Osipov about 12 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-11-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

We have a reverse proxy (nginx) accepting connections, before passing requests to Apache. Requesting the install tool directly from the Apache server produces a missing ENABLE_INSTALL_TOOL error, however requesting the same script through the proxy takes you right to the install tool login screen.

Relevant configuration values:
$TYPO3_CONF_VARS['SYS']['doNotCheckReferer'] = 1;
$TYPO3_CONF_VARS['SYS']['reverseProxyIP'] = '127.0.0.1';
$TYPO3_CONF_VARS['SYS']['reverseProxyHeaderMultiValue'] = 'first';

(issue imported from #M12811)


Related issues

Is duplicate of TYPO3 Core - Bug #20878: Remove the bypass to log in from the local loopback deviceClosedSteffen Kamper2009-08-14

Actions
Is duplicate of TYPO3 Core - Feature #23987: Install Tool always unlocked when accessed via 127.0.0.1Closed2010-11-08

Actions
#1

Updated by Marcus Krause about 12 years ago

Should have been fixed with #0011710. Unfortunately it was committed to trunk only.

#2

Updated by Dan Osipov about 12 years ago

Can we backport it to 4.2 branch, since #0011368 was applied to it?

#3

Updated by Marcus Krause about 12 years ago

Sure, I believe that the commit was a fault in a way that it has been committed to trunk only. The RFC was about 4-1, 4-2 and trunk. Feel free to bring this up in the core list, preferable as follow-up to #0011710 with a reference to this report.

#4

Updated by Dan Osipov about 12 years ago

Already done!
Thanks a lot Marcus!!!

#5

Updated by Marcus Krause about 12 years ago

You're welcome.

#6

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#7

Updated by Alexander Opitz about 8 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF