Project

General

Profile

Actions

Bug #21740

closed

creation of ENABLE_INSTALL_TOOL does not respect fileCreateMask

Added by Bernd Wilke about 14 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-11-30
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

creating the file ENABLE_INSTALL_TOOL within user-setup creates the file but just with rw-r--r-
if the FTP-/shell-user is another than the webserver is running on the file can't be deleted or updated from FTP/shell.

I got the problem after problems with the SQL-server (no BE-login posssible)
because of an old ENABLE_INSTALL_TOOL I could not access Install-tool.

the solution with a new php-file which deleted the file from php was more problematic than neccessary.
(issue imported from #M12840)

Actions #1

Updated by Mr. Jenkins over 12 years ago

  • Status changed from New to Under Review

Patch set 1 of change I2f719aff3ed14b6d1ae6eea51057b78a8f84b262 has been pushed to the review server.
It is available at http://review.typo3.org/6877

Actions #2

Updated by Gerrit Code Review about 12 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/6877

Actions #3

Updated by Gerrit Code Review about 12 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/7349

Actions #4

Updated by Dmitry Dulepov about 12 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF