Bug #21778

Enabling internal query parameters ruins links with anchors

Added by TO_Webmaster no-lastname-given almost 12 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-12-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If I set
RTE.default.buttons.link.queryParametersSelector.enabled = 1
new links of the form
index.php?id=5#c190
become
index.php?id=5#14223&

(issue imported from #M12895)


Related issues

Is duplicate of TYPO3 Core - Bug #21625: Section links coming from RTE broken in FE: rendered as #14185& instead of #c123ClosedStanislas Rolland2009-11-20

Actions
#1

Updated by Stanislas Rolland almost 12 years ago

Please test patch attached to issue #21625

#2

Updated by TO_Webmaster no-lastname-given almost 12 years ago

Seems to solve the problem. Thank you!

#3

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF