Feature #22107

Add a Hook to add Sub Categories to the Constant Editor

Added by Sebastian Michaelsen over 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-02-11
Due date:
% Done:

0%

Estimated time:
PHP Version:
4.3
Tags:
Complexity:
Sprint Focus:

Description

Currently the Sub Categories of the Constant Editor are hardcoded (Enable Features, Dimensions, etc).
Especially when you develop a flexible TypoScript Library which should be configurable with the Constant Editor it would be great if you could add custom Sub Categories.

I added a constructor to t3lib_tsparser_ext, which can also be used for other hooks or initialization stuff. Currently it only includes my Hook (callUserFunction) to add Sub Categories.
(issue imported from #M13510)


Files

addCESubCategories.diff (1.51 KB) addCESubCategories.diff Administrator Admin, 2010-02-11 10:42

Related issues

Is duplicate of TYPO3 Core - Feature #19958: Configurable Subcategories for ext_conf_template.txtClosedFrancois Suter2009-02-03

Actions
#1

Updated by Sebastian Michaelsen over 11 years ago

Please close this issue, it's already solved by #19958

#2

Updated by Christian Kuhn over 11 years ago

Resolved, duplicate of #19958.
Thanks for the pointer.

Also available in: Atom PDF