Bug #22340

Automatically hiding Option Checkboxes and search fields on "empty" list view does not work

Added by Sebastian Michaelsen over 9 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-03-29
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When you open a page in list view which has no records to display, it still shows up Checkboxes for "Extended View" and "Localization view" and a search form.
The functionality to hide these automatically is implemented but does not work anymore.

After computing the list of tables the list module checks if it has any output. If it's empty Checkboxes and searchform are hidden.

The problem ist that the "list of tables" output is never empty because t3lib_recordlist::writeBottom adds some Hardcoded HTML to the bottom of the table list.

Additionally note that rendering of the clipboard is inside the mentioned condition, so when no records are there the clipboard would also be hidden (you don't want that because you may want to paste records into an empty page). So the Clipboard rendering needs to be moved outside the if-statement
(issue imported from #M13942)


Related issues

Related to TYPO3 Core - Bug #19536: "Show clipboard" in filelist cannot be hidden Closed 2008-10-30
Related to TYPO3 Core - Bug #19537: "Show thumbnails" in filelist cannot be hidden Closed 2008-10-30
Related to TYPO3 Core - Feature #18879: Module Web>List: Enable options to hide searchbox and checkboxes and init MOD_SETTINGS from Page TSconfig Closed 2008-05-31

History

#1 Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#2 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF