Bug #22349

RTE is collapsed when loaded inside a hidden tab in Safari

Added by Oliver Hader about 11 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-03-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The rich text editor is not loaded when it's placed on a hidden tab in Safari on Mac OS X. If the accordant tab gets enabled, RTE won't load correctly (see the attached screenshot). Could not reproduce this behaviour in Firefox.

The RTE is loaded, but the editing area is collapsed (height is zero). Resizing makes it appear.

The problem exists when loading the RTE in a hidden tab in all browsers except Firefox.
(issue imported from #M13956)


Files

RTE.png (61.4 KB) RTE.png Administrator Admin, 2010-03-29 21:58
rtehtmlarea_bugfix_13956_trunk.patch (13.2 KB) rtehtmlarea_bugfix_13956_trunk.patch Administrator Admin, 2010-04-08 01:39
#1

Updated by Stanislas Rolland about 11 years ago

The attached patch fixes the issue in all browsers.

#2

Updated by Stanislas Rolland about 11 years ago

Committed to SVN TYPO3core trunk (revision 7252).

#3

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF