Project

General

Profile

Actions

Bug #22409

closed

Fatal Error Update Wizard

Added by Joerg Hauke about 14 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-04-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello,

I just updatet TYPO3 4.3.3 and I receive an error starting the update wizard:

Fatal error: Cannot redeclare user_isloaded() (previously declared in /***/typo3conf/temp_CACHED_ps0282_ext_localconf.php:1521) in /***/typo3conf/temp_CACHED_ps0282_ext_localconf.php on line 1526

(issue imported from #M14047)

Actions #1

Updated by Chris topher about 14 years ago

Let me guess: You did not delete the temp_CACHED_* files before?

Actions #2

Updated by Joerg Hauke about 14 years ago

I've just deleted those files in the typo3conf folder and the same problem still exists.
Do I have to delte them before the update?

Actions #3

Updated by Oliver Hader about 14 years ago

No, these temp-files contain all ext_localconf.php and ext_tables.php sources of your extensions.
The method "user_isloaded()" is not a method of the TYPO3 Core. You can grep for that string on the console or have a look to the mentioned temp-file and the given name.

Thus, there's a faulty extension running on your system...

Actions #4

Updated by Joerg Hauke about 14 years ago

So the problem is the faulty extension? I think I know which one it ist. It might be seo_basics becaus it throws an error on error on comparing the databas in the install tool.

Actions #5

Updated by Joerg Hauke about 14 years ago

So the problem is the faulty extension? I think I know which one it is. It might be seo_basics becaus it throws an error on error on comparing the database in the install tool.

Actions #6

Updated by Mario Colombo about 14 years ago

In my case the culprit has been found to be the extension rtelightbox.

extensions don't have to be installed to have their code included in the cached localconf.php.

I had to delete the extension directory in typo3conf/ext/ manually by rm -r

this is caused the error (in temp_CACHED_psc3c7_ext_localconf.php or something similar):

###########################
  1. EXTENSION: rtelightbox
  2. FILE: /var/www/vidaverde/typo3conf/ext/rtelightbox/ext_localconf.php ###########################

$_EXTKEY = 'rtelightbox';
$_EXTCONF = $TYPO3_CONF_VARS['EXT']['extConf'][$_EXTKEY];

if (!defined ('TYPO3_MODE')) {
die ('Access denied.');
}

/** * Check if an extension is installed * * @param string $extKey: Key of extension * @return boolean
*/
function user_isLoaded($extKey) {
if (t3lib_extMgm::isLoaded($extKey)) {
return true;
}
return false;
}

Actions #7

Updated by Chris topher almost 14 years ago

@ Jörg: And the solution is???

Actions #8

Updated by Christian Kuhn almost 14 years ago

Resolved, no change required.

This happens due to a faulty extension.

Actions #9

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF