Project

General

Profile

Actions

Bug #22488

closed

Content element "Filelink" does not create PDF thumbnails

Added by Joachim Mathes about 14 years ago. Updated about 14 years ago.

Status:
Closed
Priority:
Should have
Category:
Communication
Target version:
-
Start date:
2010-04-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If Layout 2 or Layout 3 is chosen in the "Filelink" flexform, TYPO3 should create a thumbnail of the uploaded PDF document, but it doesn't.

The problem results from method 'imageMagicExec()' in 'class.t3lib_stdgraphic.php'. The comment annotation tells us, that parameter 'frame' "refers to which frame-number to select in the image. '' or 0 will select the first frame, 1 will select the next and so on..."
But this specification doesn't correspond to the implementation. If 'frame' equals 0 or '' no frame selection is appended to the input filename and therefore the 'convert' command will create a file for every page of the PDF document:
input: file.pdf
output: <hash>-0.jpg, <hash>-1.jpg, ...
The reference to the created file is supposed to be <hash>.jpg which actually does not exist.

See patch for solution.

Furthermore this patch improves performance, if a PDF consisting of many pages is converted. Without the patch every page will be converted, but only the first one is needed actually. With the patch applied only the first page is converted.

The 4.3 branch is concerned by this problem, too.
(issue imported from #M14155)


Files

bug_14155.diff (718 Bytes) bug_14155.diff Administrator Admin, 2010-04-20 00:16

Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #21983: Thumbnail generation broken for PDF filesClosedMichael Stucki2010-01-18

Actions
Actions #1

Updated by Joachim Mathes about 14 years ago

Bug is already resolved!
See #21983

Actions #2

Updated by Christian Kuhn about 14 years ago

Resolved as duplicate of #21983

Thanks for feedback!

Actions

Also available in: Atom PDF